After a while Duplicacy Web starts failing to launch Duplicacy CLI with 0xC0000142 error on Windows Server until rebooted

I’ve been backing up to Wasabi using Duplicacy Web edition for a while now and all of a sudden i’m getting the below error :

Failed to list backup ids in the storage Wasabi: exit status 3221225794

I’ve reinstalled but the problem is persisting.

My Storage is defined as :


Any suggestions for how i can resolve this?

I’ve tried recreating the storage… and it authenticates me and lets me select a bucket, but when i click on Continue, i get the below :

Failed to check the storage at wasabi:// exit status 3221225794

Any preceding errors in the log from the wasabi backend? Can you post 5-10 lines from the log preceding this message?

A few folks seem to be experiencing failures with Wasabi recently (see this for example: Wasabi or B2 With Duplicacy (East coast Canada), I personally gave up on them long ago for the same reason)

I can’t see anything obvious… only things like this

2021/11/02 22:04:25 POST /list_repositories
2021/11/02 22:04:25 Running C:\ProgramData/.duplicacy-web/bin/duplicacy_win_x64_2.7.2.exe [-log -d info -repository C:\ProgramData/.duplicacy-web/repositories/localhost/all wasabi://]
2021/11/02 22:04:25 Set current working directory to C:\ProgramData/.duplicacy-web/repositories/localhost/all
2021/11/02 22:04:26 The CLI executable returned an error: exit status 3221225794, exit code: 3221225794
2021/11/02 22:04:26 Failed to list backup ids in the storage Wasabi: exit status 3221225794

Edit : thought i’d try and add another destination (Google) and i’m getting the same error… so this isn’t a Wasabi specific issue.

This is 0xc0000142 which is NTSTATUS of STATUS_DLL_INIT_FAILED. Duplicacy failed to execute the CLI executable. Likely due to filesystem corruption, unless you changed anything else in the system.

I would recommend launch elevated CMD and run chkdsk c: /f, enter, say yes, enter, reboot, and have it check and repair the disk on the next boot.

Then try again.

Well it turns out all i needed was a reboot of the host… thank you for (and apologies for wasting) your time and help!

That’s not a solution though… We still don’t know what happened, and if it happens again we’ll be back on the square one, (or maybe there is some underlying hardware issue – such as disk dying or bad ram, etc)

Have you happen to notice if the boot-time chkdsk find and fix anything? (i.e. was there second reboot following the check?).

I’ll admit i havn’t done a boot time chkdsk… i had to reboot for other reasons.

I will set one to run and reboot tomorrow to check.

Remember, a chkdsk with the /f (fix) flag is a potentially destructive operation and you should have a current backup (the irony :slight_smile: ) in case something goes wrong. The main job of the fix flag is to make the filesystem usable by priority - even if that means loosing some data.

So i’ve run the chkdsk and it found nothing… but the error has come back twice now and the only solution i can find is to reboot the host… which is very annoying.

At this point i’m leaning towards moving off the windows server and maybe trying docker but i’m really not relishing setting up all my storage / backups and schedules again…

Does anyone have any more suggestions for this?

I’m running on Windows 10 (fully update) with the system account… It’s been working fine until recently (when i originally posted this thread)

Edit : just to be clear, despite the title this is happening on all storage locations (currently Google One and SFTP)

Ok, so we ruled out disk corruption, which is unusual, but great.

You can try running duplicacy in the docker container on the same server; you would not need to re-setup all schedules, only storages (IIRC due to dependency on encryption) even if that, and then copy the duplicacy.json from your windows install to the docker one.

But unless we figure out the root cause – who’s to say it won’t happen again?

I might.

When it goes to that mode, try to run the duplicacy CLI manually in the folder corresponding to the backup. What folder is that you can look up in the first line of any backup log. cd to that folder, and run duplicacy CLI binary specifying the full path to it:e.g. c:\...\.duplicacy_web\bin\duplicacy_x86_cli.exe (I’m sure I’m butchering the exe name)

See if you still get the same failure; you might get extended diagnostic information printed in the CLI, and we’ll go from there.

If it does work in CMD but fails when duplicacy_web is attempting to execute the exact same command – that would be more interesting.

Do you have (or had at any point in the past – I’m yet to see an antivirus that would properly uninstall itself) any third-party security software running? Antivirus, antimalware, any of that? It may be having a false positive: duplicacy_web is technically a trojan: it downloads executable from the internet :fearful: and then runs it as administrator :scream: ! Antivirus software may not like that. Maybe they get confused and start blocking it.

When that happens – try disabling your security software and see if duplicacy starts working. In which case you can add it to exceptions.

On the related note, @gchen, does duplicacy_web do anything to address DNS cache poisoning attacks? If I spoofed duplicacy.web or GitHub or whenever duplicacy_web is downloading the next version of the duplicacy_CLI and put my own very malicious executable – will duplicacy_web reject it?

Silly question - but what changed? Any software installed? Any network configuration changed? Anything else?

And lastly – maybe run MemTest, to rule out bad ram? Unlikely, but when strange stuff like that is going on it would be great to rule that out. You can download a bootable flash drive image from and run it. It would be useful to confirm your ram is good regardless.

I’ve edited your title.

Thanks for all your input and also changing the title…

Nothing has changed other than possibly windows updates and the installation of the Jottacloud backup application… Which does touch some of the directories that duplicacy also backs up…

I’ve moved my main backups to a Proxmox LXC for now and moved the license from an old install to run that. It was never a great idea to run my backup setup on this system anyway. (due to it running other things that occasionally needing a reboot)

I’ll continue with a smaller non essential backup set on this system and see if i can run through your suggestions and report back.

1 Like