Duplicacy Backblaze B2 Help

Hi All,

I’m trying to follow the steps outlined here: Backing Up Large Datasets to Both Local and Backblaze B2 Destinations Using Duplicacy CLI on Linux to set up duplicacy to back up to B2. However, I’m stuck at the init command.

I have a Master Application Key provided by B2. I’ve also created an Application Key myself, and I see the fields like “keyID” and “keyName” in the backblaze account. I tried entering them during the duplicacy init command (tried the keyName for Account ID and keyID as key and also vice versa), but I keep getting the following error:

Failed to load the Backblaze B2 storage at b2:// Authorization failure

I also tried the Master Application Key, but I wasn’t sure what my account ID is and what the key is. I used my email ID for the ID field and the master application key for the key field, but that didn’t help either. Could someone help me with which fields need to be entered where for the init command to work correctly?


Ok, I figured it out with the help of this earlier post: Unable to init b2 bucket on FreeBSD

I missed the fact that when you create an application key via the B2 web interface, it shows a message that looks like the attached figure:


and the applicationKey value is shown only once and not after that. I missed this and did not store this value correctly. So, I deleted my existing application key and recreated another one, and saw this message. I’ve noted down the applicationKey value now for future use. So, like the above post says, for the “Backblaze account or application id”, you are supposed to enter the keyID from your backblaze account, and for the “application key” field you’re supposed to enter the applicationKey value that you’ve noted down. After this change, I’m able to init the repo now with B2.


1 Like