Duplicacy CLI 3.0.1 release

This is a major release. A new snapshot format is used to achieve near-constant memory usage so it may break backward compatibility in some cases. Specifically:

  • CLI 3.0 can read backups created with older CLI versions, so it can replace any existing CLI to work with existing storages without any backward compatibility issue.
  • Backups created with CLI 3.0 won’t be readable by older CLI, which mean if you’ve already created new backups with CLI 3.0, then you can’t switch back to an older CLI version for backup or restore.
  • However, you can still use an old CLI to check or prune backups created with CLI 3.0.

For more details on the memory usage optimization please refer to this post: Memory usage optimization


Just tried running 3.0.0 on osx_x64 (macOS 12.6 Monterey) and it’s prompting me for my password and gcd_token instead of reading it from the os x keychain. Am I missing something or did I find a bug?

1 Like

Having the same issue, also removing old entries from the Keychain did not help. Any ideas?

Access to keychain authorized to a specific app. If app is changed, access is revoked.

It can’t really be any other way, otherwise the whole point of keychain falls apart

Edit. You should have received keychain access prompt from macOS though.

Thanks for the feedback! I did not get an access prompt - I have removed the cache directory, do you have any idea how to trigger the keychain prompt?

I wonder if this has something to do with the notarization. I just did the notarization, and both CLI osx binaries are now notarized. However, you’ll still need to download the binary again, even if it is the exact same binary.

Thank you for your hard work!

I have

  • removed the old binary
  • downloaded the new binary
  • started a backup and entered my credentials

There was no keychain prompt, and when I start the backup again I get prompted again, the issue does not seem to be resolved unfortunately.

Now that CLI has moved to the new major revision, is there any chance that outstanding PRs will be reviewed any time soon? Some of them were around for 3+ years with no comments on the status. It would be helpful to understand which ones will be fundamentally no-go, need some re-work or will be merged.


Right, i did not receive a keychain prompt as is usual when I upgrade versions. Instead I got command line prompts for password and token.

I checked my binaries to see if they were notarized by running

spctl -a -vvv -t install /path/to/duplicacy

Both 2.7.2 and 3.0.0 are returning

/path/to/duplicacy: accepted
source=Notarized Developer ID
origin=Developer ID Application: Acrosync LLC ([redacted])

So I think maybe it’s not a notarization issue?

I believe the issue was caused by cross-compiling the x64 binary on my mac m1 machine. I’ll make a new release tonight.

Release 3.0.1 should fix the KeyChain issue on x64: Release Duplicacy Command Line Version 3.0.1 · gilbertchen/duplicacy · GitHub

1 Like

Sure, I’ll go through all PRs next week.


It does, thanks! Although for me, duplicacy seems to retrieve all secrets except storj ones. It writes them to the keychain, but does not read them.

I could upgrade to version 3.0.1 on my windows machine by copying the bin file to the correct folder. I am unsure of the proper steps to update my macOS. Will the GUI do the update? When I download the latest bin in the corresponding folder, it won’t work and fails to do any backups. I tried to find any documentation on this, but I can’t find any. Thanks!

on macos you’ll probably need to remove the quarantine flag after you download it, so gatekeeper allows it to run:

xattr -d com.apple.quarantine /path/to/duplicacy

you may also need to set it to executable, e.g. chmod a+x /path/to/duplicacy

1 Like

Great news!
Quick question @gchen

3.0.1 was built with Go 1.16.15 with Go modules enabled.
3. 0.0 was built with Go 1.19 with Go modules enabled.

1-Were there any regressions?
2-Any reason not to use 3.0.0 and take advantage of the latest go improvements?
3-The webGUI auto-update did not work. Maybe we should update the release endpont?


Go 1.17+ doesn’t support macOS version 10.12 or lower, so I decided to go back to Go 1.16 for release 3.0.1.

I haven’t updated https://duplicacy.com/latest_cli_version to return 3.0.1. Will do it next week if there is no issue with 3.0.1.


Sure, I’ll go through all PRs next week.

Any updates on this?

1 Like

I’m sorry I haven’t done that. It is on the top of my to do list.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.