Prune operation returned an error, FATAL: chunk xxxx can't be found


I ran into an issue while doing initial backup to a Repository containing multiple computer’s backups. Prune operation caused an error:

FATAL: Chunk 5f3456f... can't be found

I ran duplicacy check after the operation and all seemed fine. The repository is in OneDrive. I went to check there was not such a chunk on the repository.

What has happened? Is this something to be concerned?

Can you try duplicacy check -a to check backups from all computers? I suspect that the missing chunk belongs to a backup from a different computer.

Once you confirm the chunk is missing, please follow the instructions at Fix missing chunks to find out why.

Actually all chunks referenced by all the snapshots did exist so maybe this was some temporary error? I have also run prune -exhaustive -a -keep n:m after the error. That might have impacted on the issue?

Right, the -exhaustive option can remove snapshots with missing chunks. Without this option, the prune command needs to iterate through all snapshots to determine which chunks are needed.

You may still be able to find out why this chunk is missing by searching in the prune logs under .duplicacy/logs.