Storage Password Not Working

Hi everyone,

I recently started using duplicacy and it’s absolutely fantastic. Thank you gchen and the community for all the work you do.

Anyways, currently I’m on linux and have been trying to save my gcd-token and password in the preferences file. I got the gcd-token working perfectly with “duplicacy set -key” command, however while trying to do the same with storage password I cannot get working, everytime it says

“Failed to retrieve the config file: cipher: message authentication failed”

Just to clarify, I am trying to add the storage command by doing the following while in the repository.
duplicacy set -key password -value (storagepassword)

I’ve gone through this and it seems like the only key is “password” so I’m unsure of what else to try.

I must be doing something wrong, not sure, the password works 100% correctly when not using a key for the password. Any ideas?



Welcome to the forum @clumsy!

I don’t use Google storage, but wouldn’t the command have the syntax below?

duplicacy set -key client_id -value “passphrase with spaces”

I just tried “duplicacy set -key client_id -value “passphrase with spaces””

and it still asked me for my “storage password”, so I’m not sure if that’s right.

Any other ideas? After reading the passwords and credentials page it seems like it SHOULD be password.

I’ve tried doing the " export DUPLICACY_PASSWORD= (password) inside a script as well as (storagename)_password that didn’t work either. Any other ways to automate typing in the storage password in a script?


Have a look at this: How to use the cli with sftp, without always getting prompted for the private key

You can specify the storagename_password in the .duplicacy/preferences under keys section either manually or with a duplicacy set

I haven’t looked at that specifically but I’ve been editing the preferences file manually for a while trying a bunch of different things but none have worked, it still asks for the storage password.

I’ved tried, (name)_password, (id)_password, local_password), gcd_password, and duplicacy_password. I just can’t get it working for some reason, at least gcd_token works.

Any other ideas? My cloud storage is google drive and I’ve tried basically everything in Passwords, credentials and environment variables


Did you try password in the preferences file? You can also run duplicacy -d list to find out where the password is read from.

If you do this, remember you’ll need to properly escape certain characters - e.g.:

Not sure what the solution was, but had to reinstall my Ubuntu and using normal “password” worked, I could’ve sworn I tried this before. But anyways, thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.