B2 backend does not support non-ascii characters in storage name

planned
backup
backblaze-b2

#1

Please describe what you are doing to trigger the bug:

I defined a snapshot ID with non-ASCII 127 characters (Scandinavian ‘ö’) and tried to backup files.

id: “snapshot-id-with-äöå

Please describe what you expect to happen (but doesn’t):

I was expecting Duplicacy can handle non-ASCII (UTF-8) characters in snapshot-ID names.

Please describe what actually happens (the wrong behaviour):

The backup uploaded all the files, but Duplicacy was unable to upload the snapshot file in the end:

URL request ‘https://pod-000-1099-18.backblaze.com/b2api/v1/b2_upload_file/abbcxxxxxxxxb1c061490a13/c001_v0001099_t0014’ returned status code 400

… (received this error message multiple times)

Failed to upload the file snapshots/snapshot-id-with-äöå/1: Maximum backoff reached

I tried to manually create a folder to B2 with Scandinavian characters using the B2 web-UI and I succeeded without any problem. Therefore this might be a bug related to how Duplicacy B2-backend handles snapshot ID filenames. I have used the same snapshot ID with Onedrive without any problems.


#2

gchen has confirmed the bug and it is now under investigation.