Backup Email Not Sending for Scheduled Backup


Our backups have been failing for a week without anyone noticing due to backup failure emails not sending. I recall from other tickets that sometimes the GUI and Services conflict at times, but I’m fairly certain only the service is running (from what is reported in Task Manager’s Detail tab).

Checking the log file, it is saying that the storage is uninitialized (working w/ coworker to establish this wasn’t a mistake on our end…may be submitting another post if it wasn’t something we did purposefully).

I tried:

  • stopping the service
  • starting the GUI as Administrator
  • sending a test email (which sent successfully)
  • clicking “Start” on the GUI to schedule the backup
  • exiting GUI
  • restarted the service

I still did not receive a failure email.

Did I miss something in these steps?

Do you have the Send email only when backup fails option enabled?

Also check the version. If it is not the latest version 2.1.2 please upgrade and test again.

The Send email only when backup fails option is not checked. I was on version 2.1.0, so I upgraded to 2.1.2, and still experienced no email for a failure.

It is a bug that the email notification didn’t get sent when there was a failure. Can you try this 2.1.3 build that fixed this bug:

So I installed 2.1.3, and despite a backup running successfully, I still do not receive an email.

It worked in my testing. Can you double check?

Make sure you don’t run the job manually – it only sends emails after scheduled runs.

Sure, just double checked after a couple runs. I noticed that the schedule file had its “backup_scheduled” setting as false, despite setting the “start” value on the GUI as Administrator. I stopped the service, started the GUI, and it said it was scheduled, so I stopped and re-scheduled it.

Quitting the GUI, I checked the settings file again and the value was still false. I manually set it to true, and restarted the service. The backup successfully ran, but with no email.

Can you try running the scheduled job in the GUI to see if the email is sent? You’ll see a log message saying email has been sent to ....

The service has the same code path as the GUI so if one works the other should too.

So ran the scheduled backup in the GUI, received this:


If you need any other output, I can provide that.

I know you said you sent a test email, but your screenshot doesn’t show that it’s using the usual TLS port - i.e. smtp://

Also, you may need to make a small change to your Google Account.

The odd thing is that this email account and server specified used for sending emails works on two of my 4 servers.

That is interesting.

Were I in your shoes, I might export the Duplicacy registry settings on each server (assuming you’re using the legacy GUI) and compare them with something like Beyond Compare. Could just be something as simple as a typo.