Backup of zero byte files

backup

#1

I think I may have discovered a very minor bug in backing up zero byte files, but not critical because the backup worked properly, meaning the zero byte files were bacled up properly.

  • This is using latest CLI.
  • My back end is OneDrive (It could also be a OneDirve problem, as it is not possible to uploade zero byte files via the OneDrive website)
  • Win10 Pro x64

Please describe what you are doing to trigger the bug:

  1. I ran my backup to make sure all files have been backed up.
  2. I then added 2 zero byte files files (no content) at different folder locations.
  3. I then ran my backup again

Please describe what you expect to happen (but doesn’t):
4. I expected to see in the backup summary New Files = 2, zero bytes uploaded.

Please describe what actually happens (the wrong behaviour):
5. The backup summary showed New Files = 0, zero bytes uploaded.

  1. I then listed my last backup and I could see the 2 new files in the list. I did not actually attempt to restore them, because I assumed if they are listed then they are backed up ok.

regards