Cannot add Gdrive as storage option "rate limit exceeded" trying to add


Trying to evaluate GUI version of what looks to be an awesome product here, I’ve tried on both Ubuntu server and Windows 10 to get this going…

I’m at the point where I’m in the storage tab and trying to add G.Drive as storage, I selected my token, the GUI shows me the folders in my G.Drive (so it’s connecting ok), I pick the folder and get to the page where it wants me to select a name for the storage and I click “Add” and it just stalls forever and eventually i get a Error: userRateLimitExceeded.

That’s it, can’t get any further.

This is a Gsuite account with unlimited storage, etc. The below image is as far as I can get on either linux or windows

Few things here.

If you created a token via duplicacy web site you will be sharing constrains with all other users. It’s best to create a token from your own project. Taking this one step further, and to avoid messing with renewals, you can use service account. this may be helpful.

Before that, to ensure that there are no other sheningans (such as wrong credentials, that app keeps retrying with), I would try to configure duplicacy backup in the command line, with the -d flag passed, to see extensive logging and confirm whether the throttling is genuine or a symptom of another bug. I’m not sure if duplicacy_web is logging sufficient information in this scenario-- check duplicacy_web.log just in case.

that seemed to have worked but I can’t test it because I can’t figure out how to create backups of network drives. When I click to create a new backup the only option is C: but the whole point of this is to backup my 3 main network locations from my NAS.

OK so that worked…insane question here, so i’m doing a trial backup…WHERE are these files going? How can I go see or remove them from G Drive?

If you used drive.appdata scope, the data will be in the hidden application-specific folder in your google drive. You can see how much space is it using in Settings → Manage Apps in your google drive.

You can feed the same token file to another file browser, such as Cyberduck (I haven’t tried) or rclone (it works) to see the files. Generally, you should not need to – you shall be managing this via duplicacy. But if you have to, for troubleshooting – these would be options.

Click on that Options button, there will be an option to delete data:

If you don’t want to use hidden folder, and instead dump everything into My Drive – use drive.file or drive scope instead of drive.appdata, as described in the blog post. Don’t try to use Shared/Team drives: you will hit their limitations on amount of files very quickly.

It seems the issue is the backup is going to the service accounts hidden space which instantly filled up, instead of to my actual gdrive which has 30TB available, kind of stuck on that one, i did the extra lines in the JSON for the impersonation but that doesn’t seem to be doing it.

The change in duplicacy that adds support for honoring impersonation was merged on March 9 2021, but the latest official release was made on Nov 16, 2020: Releases · gilbertchen/duplicacy · GitHub

I think you’ll need to rebuild duplicacy from source. Or if you want to be extra cautions – checkout the currently released branch and merge that PR manually, and build.

thanks for that…I think i got GO installed and then did the build…is it just the CLI version? not the web GUI?

Yes, all the work is done by the CLI version. Web version is just a launcher.