Can't access web interface anymore

I’m on Windows 1.5.0 and tried uninstalling and reinstalling for all users as a service. I’ve tried different browsers. Nothing else is using that port. It seems I can’t connect to the web page at all.

If I force stop the service and try to open the app as an admin, it says it can’t bind the port.

I tried editing the settings.json in both ProgramData and user folders to a different port and restarted the service, but no dice either.

On windows there can be mints than one duplicacy. One as a service account and one per user all attempting the same port.

Open task manager as admin and ensure all instances are actually killlwd.

Yup, only one instance in taskmgr. I also used another app to see if anything else is using that port (nothing).

May I suggest that the next version limit the program to only one instance?

So, if you close that last instance, and then launch it again (is it the one that runs as a service?), in the duplicacy_web.log it complains that it can’t bind to the socket in-spite of there being no other app in the system holding the socket?

How is the listening address configured? or or specific lan adapter? (You can look it up in settings.json

The better approach would be to change the port for each instance. There is a legit usecase for having multiple instances. For example, on macOS to avoid giving an app full disk access. Duplicacy today does not support this common scenario without users having to configure ports manually.

Ugh. I finally managed to launch the web interface with an icon on my desktop, but upon further inspection it is using some old settings from a year ago. So, I uninstalled that instance and I’ll see whether I can find my more recent install. I still don’t understand why it would be so easy to install or run several instances of a program designed for regular users.

That means you still have another instance Installed.

Once the app is running access the user interface with a bookmark in the browser at http://localhost:3875 or wherever other port you’ve configured

There is a legitimate usecase to have it installed for each user and in the system concurrently, but it takes care to assign unique ports to each instance.

Its a balance between flexibility and ease of use.

In your case your have multiple instances installed, using the same port, and you are launching them indiscriminately from multiple locations.

My suggestion would be to uninstall all instances, (search your drive for duplicacy_web), delete all shortcuts you might have created, and then install one instance the way you want — to the system for the single user. Then it will work in a consistent and predictable way.

What duplicacy can do better if the second instance is being installed (user one when system one exists or vice versa):

  • warn the user from the installer and confirm that that’s what they want. Give a choice — [un]install system instance, [un]install user instance.
  • create separate, clearly labeled shortcut Duplicacy System vs Duplicacy
  • automatically configure different port.

. I still don’t understand why it would be so easy to install or run several instances of a program designed for regular users.

The current behavior that the install target is determined by whether the installer was launched as admin is very bad: unintuitive and non-discoverable, and is the source of confusion for windows users all the time.

Regardless of how it was launched there always has to be a choice to be made on how to install. And if user chooses system — the privilege elevation shall be requested right there.

It’s likely will require writing an installer as opposed to using an off the shelf one — but this needs to be done.

1 Like