Can't run Windows service with Duplicacy Web 1.7.0

Continuing the discussion from Duplicacy Web Edition 1.7.0 releases:

I am new to Duplicacy and would like to run the app as a Windows service on a couple PCs running Windows 10 and Windows 11.

I am able to install the app on both PCs, and run it manually from the Windows taskbar. The service installs, but does not run. Attempting to start the service results in an error, please see screenshot below. This occurs on both PCs. Any troubleshooting suggestions? Thanks!


Hi, same for me, 1.7.0 fail to start, if i rollback with 1.6.3 installed as a service that works well.

1 Like

I see nothing revelant in windows logs :confused:

I just tried that and it worked for me too. In other words, I can run Duplicacy Web as a Windows service with version 1.6.3, but not 1.7.0. Thanks for pointing that out. Hopefully the underlying issue in 1.7.0 can be identified.

Edit: I have moved this thread from the “support” category to “bug.” I can never be sure the underlying issue isn’t an example of PEBCAK unless someone else has verified they appear to be having the same problem as me :slightly_smiling_face:.

I can confirm that this is a bug, due to the unavailability of the system tray icon in the service mode. Since there were no relevant code changes in version 1.7.0, it is likely that the bug was triggered by the new Go version used for 1.7.0.

I’ll make a new release tomorrow.

1 Like

Great, many thanks :wink:

I uploaded a 1.7.1 release for Windows only which should fix this bug:

1 Like

Thanks I will install and run the service!

Windows service is installed and running after installing v. 1.7.1.

Thanks again!

It’d be really nice if one day we can get that back (as an option). The legacy UI had a separate tray process for showing status and launching the app. Not to mention, the desktop shortcut is unsuitable for service mode.