Check command no longer working in the old bucket

check

#1

I should be making a pretty stupid / basic mistake, but I’m not understanding what’s going on …

I have a bucket in B2 to which I was backing up a 2Gb container, and I already had dozens of revisions.

Now I have to backup a second container to this same bucket, but I decided to create a new bucket to adjust the nomenclature (as far as I know B2 does not allow renaming of buckets).

So I created “bucket2” and copied the entire contents of the old “bucket1” into the new one (using Rclone), I ran a check in “bucket2” and everything was ok. I created the new backup of the new container (new snapshot id), everything 100% ok. The check command in “bucket2” now shows the revisions of the two snapshots perfectly.

However, when I run a check in “bucket1” (the old one), now I get:

2019-04-30 13:38:11.688 INFO REPOSITORY_SET Repository set to [redacted]
2019-04-30 13:38:11.708 INFO STORAGE_SET Storage set to b2://[redacted: "bucket1"]
2019-04-30 13:38:14.970 ERROR STORAGE_NOT_CONFIGURED The storage has not been initialized

:interrobang::interrobang:

All the files are still there (config, snapshots, chunks, etc)

Any suggestions on what might have happened?

(I don’t need the old bucket anymore and I’ll delete it, but I’d like to understand what happened)


#2

Wild guess here but if you rename an encrypted snapshot, everything breaks coz snaphshot id is stored somewhere. Could you have hit this issue?


#3

The point is that (theoretically) the old bucket was not changed at all, the files were just copied from it.

Investigating a little more I discovered that B2 generated a new version (?!?!) of the config file in the old bucket when I copied the contents to the new bucket:

I downloaded this “new” version and the previous one and the files are exactly the same …

One thing I remembered is that when I run the first command (check) on the new bucket (after copying all the old bucket files) Duplicacy asked me for the password, as if it was the first backup.

I’ll do this same procedure (create a new bucket) with another set of files. Let’s see what happens.