Checking chunks and files

check

#1

Hello,

Today I ran the command "duplicacy check" to check that all chunks existed.

Duplicacy reported that all chunks for all my revisions existed

Right after I ran the command "duplicacy check -files" to check the integrity of each backup file.

After some time duplicacy reported "fossil erg66dgy6… Has been resurrected" which means to me that that fossil had been converted back into a chunk.

If the check command reported all chunks existing but the check -files command converted a fossil back into a chunk, that means to me that there was a chunk missing and therefore the check command reported incorrectly.

I am hoping someone can explain how that can be otherwise I may have to assume that check command has some bug in it.

cheers


#3

A fossil is just a renamed chunk. Only when a fossil is deleted by a prune operation does the chunk become missing.

There might be a prune operation that turned the chunk into a fossil. You can check the log files under .duplicacy/log to see if this is the case.