Chunk can't be found error

I have two storages, one local and one on Backblaze B2. I have had to move the local one around a bit because I’m restructuring my infrastructure. I ran a copy to copy my latest backups offsite. Then I ran a purge and check on my local. Everything went find up to there. Then I ran a purge and check on the Backblaze B2 storage and it goes for a bit and then throws this error:

ERROR DOWNLOAD_CHUNK Chunk 1ff70847c36ddbc42ee087744f1eb2da703d7ebe96ab445a2d3c781c323c6c54 can’t be found

I read a few other posts with similar errors, but I not 100% sure what I need to do and figured I’d ask before doing anything.

By purge do you mean prune? Have you tried check -fossils?

I did mean prune sorry. I will give the check a try.

I received the same error when running check -fossils

This turned out to be a cache issue. I must have had a storage already on this server with the same name. Once I added the storage with a different name and re-ran the checks and prunes, everything worked fine. It seems when you remove a job and storage via the web UI, it must not clean up everything.