CLI 2.7.0 is now available

Release notes:

Web GUI users: it looks like there is a bug in the Web GUI where it can’t automatically download the latest version on restart even if this option is selected in the Setting page. To force it to use CLI 2.7.0, you can remove all CLI binaries under ~/.duplicacy-web/bin, or setting the cli_version key in ~/.duplicacy-web/duplicacy.json to 2.7.0.


Here it downloaded the new .exe CLI without problem.

Added exclude_by_attribute preference to exclude files based on os-specific extended attributes:

Yay!!! I can’t believe I’m seeing this! Going to test it out right away!

However this API is still returning old version:

% date
Sun Sep 27 19:31:17 PDT 2020
% curl


@gchen, it works, but the exclude_by_attribute flag shall be true by default/if not defined. I can’t imagine anyone would ever want to turn it off; not backing up data explicitly marked as not needing backup is a sensible default behavior.

I did both but it still doesn’t work:

Running check command from /tmp/.duplicacy-web/repositories/localhost/all
Options: [-log -v check -storage pcloud -a -tabular]
fork/exec /.duplicacy-web/bin/duplicacy_linux_x64_2.6.2: no such file or directory

I get the same error message even when I manually put the new binary into /.duplicacy-web/bin/. It seems to be looking for 2.6.2 and nothing else. The only way I got it to work was by renaming 2.7.0 to 2.6.2.

How do you see what version number the Web Edition is using?

Just checked my .duplicacy-web\bin directory and among the many revisions, the latest is only v2.6.1. Can’t see version numbers in any of the logs.

Edit: Nevermind! See it under Settings. :slight_smile:

@gchen - curious to know - would a future Web Edition version fix the CLI revision download?

You probably have cli_version set to 2.6.2 in your duplicacy.json file?

Yes, the next thing to do for me is a new web GUI release that includes this fix.

No, I followed the instructions above and set it to 2.7.0. At least the one in /.duplicacy-web/duplicacy.json. Is there another one?

Did you restart the web GUI?

No. So it only checks for updates when its restarted? I can’t find any button to restart it. Does it have to be done via ssh?

This topic was automatically closed after 20 days. New replies are no longer allowed.