CLI install error in duplicacy_webdavstorage.go

Trying to install Duplicacy CLI on Raspberry Pi 4 B with newly installet go1.11.6 linux/arm like this:
sudo go get -u -v

After a good while and many output lines it stops with this error:
duplicacy_webdavstorage.go:238:33: undefined: response

These are the last lines of the output:
/root/go/src/ undefined: response

The code line where the error occurs looks like this:
defer io.Copy(ioutil.Discard, response.Body)

Please advice!

This is an error caused by copy and paste in a previous commit. response.Body should be readCloser.

I’ve fixed it with this commit: Fixed a compile error in previous checkin · gilbertchen/duplicacy@40243fb · GitHub.

You can remove and try again.

1 Like

Excellent! Works fine now.
Thanks for quick fix!

For everyone: Feel free to use the :heart: button on the posts that you found useful.

For the OP of any #support topic: you can mark the post that solved your issue by ticking the :checked: under the post. That of course may include your own post :slight_smile:

This is much better than renaming the issue and adding [RESOLVED] or SOLVED, as it allows us to find issues which are solved via search in a standard way:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.