Connected storage not displaying existing snapshots

I have a CLI backup on a machine and I just noticed that on the storage for it there’s not been a recent snapshot since September of last year. So my script somehow silently failed, perhaps in combination with running low on disk space on the storage.

So now the check command is just returning a supposedly empty repository:

Listing all chunks
1 snapshots and 0 revisions
Total chunk size is 0 in 0 chunks

However, listing the chunks folder, I see recently modified chunks folders. The snapshots folder lists over 100 snapshots.

I already tried renaming the cache for the storage in the cache folder within ./duplicacy, but that didn’t help.

How can I get duplicacy to sync up the local cache with the existing snapshots on the storage?

Thanks!

Which storage backend is this?

The snapshots folder should be structured like this:

├── snapshots
│   ├── id1
│   │   ├── 1
│   │   ├── 2
│   │   ├── 3
│   ├── id2
│   │   ├── 1
│   │   ├── 2
│   │   ├── 3

Is this what you see?

The storage is on a SMB mount mounted like this:

cifs (rw,relatime,vers=3.0,sec=ntlmssp,cache=strict,unc=,username=,domain=WORKGROUP,uid=0,noforceuid,gid=0,noforcegid,addr=,file_mode=0755,dir_mode=0755,nounix,serverino,rsize=65536,wsize=65536,actimeo=1)

The snapshots folder on the storage only has one ID folder and within it there are 107 snapshot files (1 to 107).

This is likely a permission issue. Please make sure that the user that runs Duplicacy has the permission to list the snapshot ID folder.

I run duplicacy as root and the storage has the following permissions:

drwxr-xr-x 0 root root   0 May 27  2022 chunks
-rwxr-xr-x 0 root root 842 May 27  2022 config
drwxr-xr-x 0 root root   0 May 27  2022 snapshots

and this is the snapshots folder:

drwxr-xr-x 0 root root 0 Jan 17 03:46 BeagleData

and here’s the first snapshot within that folder:

-rwxr-xr-x 0 root root 9254 May 27  2022 1

To me, the permissions look okay. Do you see anything off?

Thanks!

Can you try to add an SFTP storage to access the same folder via the SFTP protocol?

The storage is on my router and it only supports ftp and smb. However, I do have a different machine also connecting to a storage on my router for back up via Duplicacy. It has no problems.
It has the storage mounted like this:

cifs (rw,relatime,vers=3.1.1,cache=strict,username=,uid=0,noforceuid,gid=0,noforcegid,addr=,file_mode=0755,dir_mode=0755,soft,nounix,mapposix,rsize=65536,wsize=65536,bsize=1048576,echo_interval=60,actimeo=1)

On the machine not working, I can’t use smb beyond version. I’d have to first install a more recent linux disto.

Can you ssh into your router? If so then most likely sftp is already enabled.

So Duplicacy running on a different machine can see those revisions correctly?