Copy: Failed to decrypt the file snapshots/backup2/1: cipher: message authentication failed

copy
prune

#1

I have a problem with copying from source (Windows filesystem) to a Google drive. I am on 2.1.2 release on Windows 10 x64. The story so far:

  1. I copied id backup1 from source to gdrive without issues. I started copying id backup2, but this got disrupted after one hour or so due to a network issue.

  2. Now, for many revisions I get the error:
    duplicacy copy -id backup2 -r 1 -to gdrive
    Failed to decrypt the file snapshots/backup2/1: cipher: message authentication failed

I am aware of several posts here that reported the same problem. What I tried so far to resolve the issue:

  • Delete keyring to reset storage password, no success.
  • Pruning gdrive with duplicacy prune -exclusive -exhaustive -storage gdrive, also no success.
  • I even tried pruning from the source with duplicacy prune -exclusive -exhaustive -id backup2, again without success.

I am now a bit puzzled and confused that an aborted copy command seems to have messed up my backup at the source. I have just completed chkdsk on the source filesystem without any errors. The pruning commands and neither the source nor the destination nor the source reported any output, which I also found a bit surprising.

Any help would be appreciated.


#2

Does list or check give the same cipher error?

My guess is that the cache (under .duplicacy/cache) is somehow messed up. However, if your default storage is a local storage the cache should be disabled. It is always safe to completely nuke the cache directory but if you want to figure out the root cause it may be worth to make a copy before doing so.


#3

It would be bery helpful if you could link to these posts as it will not only create a reverse link to your post from there but also notify the authors of those previous posts that you are continuing the discussion.