Delay When Running Duplicacy CLI From Local Terminal

Downloaded latest Linux x64 CLI release from:

Ran “./duplicacy” from local XFCE terminal (xfce4-terminal) in Debian 12 x64.
Sat at a blank output for 2 minutes, then outputted help text and returned to the shell.

However, when run from an ssh session or as part of a cron job, the delay doesn’t occur.
$ ssh localhost
$ ./duplicacy

This makes testing scripts or manually running Duplicacy tasks very slow, as each command will take 2 minutes just to start running.

Have you tried different terminal? Maybe try getting stack trace at the point when it appears hung? Or run it under gdb/lldb and see what takes a lot of time?

Do you have any security software running? Maybe something with AppArmor/SELinux shenanigans?

No security software running. Tried xterm too, and it also did it.

I’m not sure about how to get a stack trace.

I’ll try GDB and see if it gives anything useful.

Doesn’t look to be useful, just around 4 “New LWP”, stalls, some more “New LWP”, then the help text.

this is quite strange. go apps are self-contained executables, there are not really any dependencies that could matter.

What shell are you using? The difference between ssh session and local terminal can be in the different profile files being sourced (e.g. zshrc vs .zprofile vs .zlogin)

strace may help pinpoint where the problem is:

strace ./duplicacy_linux_x64_3.2.3