Did packages stop working with DSM 6.2.4?

You made the v1000 package in response to my request. I promptly installed it and started a backup of 7TB worth of data to B2. Ran for four days until it was done. Now for some reason, Duplicacy won’t start. It occurred to me that I’d upgraded the firmware on my 1821+ once the backup was done.

Any ideas, @gchen?

While we wait for the cat and mouse chase between package developers and Synology SDK maintainers (or for when Synology understands that breaking existing stuff if bad… am I too naive here?) — as a (permanent?) workaround you can install duplicacy_web on your disk/rack station natively: Duplicacy Web on Synology Diskstation without Docker | Trinkets, Odds, and Ends

I did what described in the article before Synology packages existed and it seemed to work fine.

The log file /volume1/DuplicacyWebEdition/logs/duplicacy_web.log may contain some error message that can explain what went wrong.

You can also run this command to start the web GUI manually:

env HOME=/volume1/DuplicacyWebEdition /usr/bin/duplicacy_web

Hey Gilbert,

So I looked, and it seems as if the package got uninstalled on the firmware upgrade.

When I ran the commands, it was as if there was no “duplicacy_web” binary there.

I reinstalled the package, and it seems to have forgotten about the previous 7TB backup to B2, as well as the fact that this was a licensed install.

Is there any way I can get it to reload (for lack of a better word) state, so it knows about the previous backup that resides in B2?

Thanks,

Aaron Kulbe

You’ll just need to add the b2 storage and you should see all previous backups. Then create a new backup using the same backup id, and the revision numbers will continue from the last one.

For the license just reactivate the license by clicking the license link next to the host name on the backup page and then entering the license code.

Is there a way to prevent this disruption before installing 6.2.4? Just curious. Still learning the software, and having to re-enter all my backup tasks and schedules seems daunting.
Thanks!

6.2.4 has been a dumpster fire. Any specific reason you want to update to it?

Regardless, you don’t have to use Synology packages to run duplicacy there; for example, you can do something like this: Duplicacy Web on Synology Diskstation without Docker | Trinkets, Odds, and Ends

6.2.4 has been a dumpster fire.

OK… but then there will be 6.2.5… I use other third party spk’s without this happening. Can the spk be fixed to prevent reinstallation?

I’ll look at the link, but I fear with my experience level that it may lead to other issues… I’ve finally substituted Duplicacy and Rclone for nearly all Hyper Backup tasks, and I would like to avoid recreating the tasks and losing continuity with the backups I’ve taken.

A firm upgrade may update /usr/bin and as a result remove /usr/bin/duplicacy_web which is a symlink to /volume1/@appstore/duplicacy/usr/bin/duplicacy_web.

I suspect other than that the upgrade doesn’t remove the package. If that is the case all you need is to recreate the symlink:

ln -s /volume1/@appstore/duplicacy/usr/bin/duplicacy_web /usr/bin/

Via MacOS Terminal (ssh) I ran that command as a Synology admin account and got the error:

failed to create symbolic link ‘/usr/bin/duplicacy_web’: Permission denied

Edit: I added “sudo” in front and it ran successfully. It also fixed the issue, I’m now able to start Duplicacy on my Synology without having to reinstall it (after the 6.2.4 update).

Wondering if there’s anything you could do to stop this from happening going forward?

It looks like there is no need to create /usr/bin/duplicacy_web and Duplicacy should not rely on this symlink to start. I’ll fix this in the next release.

1 Like