Drive is not ready

I just installed duplicacy to test it out and experiment with it.

Once installed, i added the storage option for drive Z:

i hit add and everything is great. However, as soon as i hit the backup tab, and try to select the drive i want to backup, it gives “drive not ready”

all other drives will open up, but not drive D:

Drive D is a partition of the main drive. so drive C and D are on the same ssd. Drive C opens just fine, but drive D gives the error “device not ready”

i ran chdesk, wmic, and other utils to check the health. all report back healthy


Did you install duplicacy for a current user or as a service for all users?
Is drive D: readable by the user dupicacy is running as?

1 Like

when i installed duplicacy it never asked for the option of all users, i looked for it, but it never showed it. I only have one user account on this machine, admin. so maybe thats why it never asked which users during install?

Yes, drive D is readable. That is my main data drive. I install software there, it has all the windows default folders such as pictures, music, videos, my documents, all on that drive. IE, i changed the path of the default location of my documents from C to D

as of right now, i have duplicacy using a differnt drive as the backup until i can get the D drive “ready”


Depending on how you have set that up and how duplicacy is attempting to open the drive there may be some permission missing. Generally it’s not advisable to mess with windows defaults, it’s not very stable as it is. Especially if both drives are on the same SSD there is no benefit in splitting inherently connected things into two volumes. There may be some ACL or entitlement missing on your D drive.

Uninstall it, and then run installer with elevated permissions (right click → run as administrator, IIRC). Then it will ask whether you want to install it as a service. This may be enough to ensure duplicacy has enough permissions to read the drive.

You want to run it as a service anyway—for it to be able to use VSS. Otherwise, it cannot guarantee coherency.

1 Like

ok, i will uninstall it and see what happens.

However, im guessing switching the defaults could cause an issue like you say. I have always kept my data separate from the OS, but i have never messed with the defaults until windows 10.

Let me uninstall and retry.


after reinstalling and selecting all users and start as a service, i now can not open the web gui


Your previous webui instance is still running, most likely, so you need to kill it first.

i restarted the system and it says the same error.

i just did a second PC restart and still same error. nothing else i use server wise even uses that port number

EDIT: I got it to work. edge kept trying to open the gui over and over and over…WTF edge

and it still gives drive not ready… must be a permissions thing

Make sure you uninstall the first instance. Then restart the service or reboot the host. Then open the web ui by navigating to the URL in the browser, don’t launch the application.

Otherwise you are likely still talking to the instance installed for the user: if it starts first it will open the port first, and the service will fail.

1 Like

thats how i did it. What was going on was microsft edge kept trying to open multiple instances of the web gui for some odd reason. Edge does some weird stuff. Wish i could use firefox but i cant because my schools online platform does not work with firefox.

anyway, im back in the GUI but still same issue with device not ready. Im guessing permissions. So to work around it, i copied the files i want to backup, and put them on another drive that duplicacy can open.

So here the next question. I have my first backup scheduled for tonight at 2am. Once the files are all copied over, if i make any changes to any of the files, will it update the backed up files with said changes? because windows 10 autobackup does not…

What do you mean? It was trying to navigate to that url multiple times? That’s harmless. Browser cannot launch applications for you. And that message box was new duplicacy instance complaining that it cannot capture the port and exiting.

The way installation of duplicacy is handled on windows needs a lot of improvement.

You can use different browsers for different things :slight_smile:

In the task manager find duplicacy_web process and check which user accounts is it running under.

Yes, it will create a new snapshot for the new state of your files.

You mean File History? It keeps version history as well. I’m not familiar with auto backup (but I haven’t used windows for a while).

1 Like

hmm, then i wonder what was trying to launch the application then, but now it is working.

You can use different browsers for different things :slight_smile:

I know, i just hate having so many installed. Just want one to work for everything haha

You mean File History? It keeps version history as well. I’m not familiar with auto backup (but I haven’t used windows for a while).

the auto backup option in windows 10, only copies the original file or folders in the parent directory. Its a known issue and bug according to the microsoft forums. So lets say i have a folder called school files. in said directory are 30 folders, maybe 20 files etc. Windows auto backup will backup the original files. But if you add more folder or images, it will not look for changes at all. Its supposed to, but it doesnt.

Yes, it will create a new snapshot for the new state of your files.

Am i able to actually see the files in the snapshot? IE, lets say i only need one file or want to look at one image i have in the snapshot, can i browse those files? or is a snapshot a single “file” that has all the data in it?


Wow. just wow. No comment here…

Define “see”? You can use duplicacy to enumerate revisions, files in each revision, and restore a bunch or all files from a specific revision. There is a feature in the works to mount the revisions as a filesystem for you to be able to browse with native tools such as Explorer. But if you’re asking whether duplicacy keeps your files plaintext at the destination—then no. You can look at what’s there—a few folders with binary encrypted chunks. But this is not unlike NTFS nor any other file system—it’s an illusion that is created for you to represent binary data with higher abstraction level. Here is a good discussion on this exact topic, to avoid repeating this here: File Format/ Accessbility. You may also want to read the paper if you are interested in how duplicacy works.

1 Like

Ok, so i have duplicacy backing up to a mapped driver over ssh using sftpDrive software.
if i browse the files of the mapped drive, will i be able to see the actual backed up files like if i did a copy/paste sorta speak?

Backup directly to SFTP server instead of mounting it and backing up to a mounted disk: doing the latter only reduces reliability and introduces unnecessary complexity, failure points, and risk (e.g. ransomware destroying your backup much easier).

Please read the topics I linked in my previous comment.

1 Like

i am reading the paper now. Thans for that information.

ok, ill change the settings now then and not backup to the NAS via ssh.

My key has a passphrase, will that be an issue? i cant remember if duplicacy can hanlde passphrases or not?

well, duplicacy may be able to handle pass phrases but it doesnt like my key for some reason. I am using openssh and all the other sftp clients use this same key just fine…

You mean the opposite, right? It’s ok to back up via ssh.

I think it was implemented long time ago: SSH key with passphrase

1 Like

yeah, i ment the opposite haha.

ok, keyphrase worked, just labled password is all, however, duplicacy does not like the key. All my other clients used this key. I might have to recreate key pair just for duplicacy in a newer cipher?