Duplicacity web restore crashing internet

Hi there, Iam trying to restore a simple file, but every time I do. My router crashes and goes offline and have to try reloading the web page to restore a file.

Iam currently on unraid using hotio docker image. my unraid server is plugged into a wireless adapter as i cant not physically move the server to be connected directly to the router. is there some idea why this might be happening? its a talktalk H.1.01 router? Is that the router is not powerful enough or something?

this is the log i get
2022-11-13 17:24:25.668 INFO REPOSITORY_SET Repository set to /Hoard/downloads 2022-11-13 17:24:25.670 INFO STORAGE_SET Storage set to /localbackup 2022-11-13 17:24:25.670 INFO SNAPSHOT_FILTER Loaded 1 include/exclude pattern(s) 2022-11-13 17:24:25.705 INFO RESTORE_INPLACE Forcing in-place mode with a non-default preference path 2022-11-13 17:24:25.706 INFO RESTORE_INDEXING Indexing /folder/downloads 2022-11-13 17:24:25.706 INFO SNAPSHOT_FILTER Parsing filter file /cache/localhost/restore/.duplicacy/filters 2022-11-13 17:24:25.706 INFO SNAPSHOT_FILTER Loaded 0 include/exclude pattern(s) 2022-11-13 17:24:28.551 INFO SNAPSHOT_VERSION snapshot folder-Duplicacy-Backup at revision 24 is encoded in an old version format 2022-11-13 17:26:33.902 INFO RESTORE_START Restoring /folder/downloads to revision 24 2022-11-13 17:26:34.114 INFO DOWNLOAD_PROGRESS Downloaded chunk 1 size 7960848, 60KB/s 00:00:01 100.0% 2022-11-13 17:26:34.115 ERROR RESTORE_CHOWN Failed to change uid or gid: lchown /folder/downloads/folder/archives/backups/file to restore.txt: operation not permitted

So it looks like it fails even when trying localhost. why?

Thankfully, I do have a second way of restoring, but at least I know that duplicacy can back up, but can be a challenge to restore.

I’m not sure how Duplicacy could crash the router, but the error in the log was a permission issue. You can run the web GUI as administrator to give it enough permission to change the uid or gid. Alternatively, add the -ignore-owner option to the restore page so it won’t attempt to restore the original uid or gid.

Off-topic. Consider getting a pair of powerline adapters - wireless connectivity on a home server is yuck.

… or Moca Amazon.com : moca adapter, for better performance and lower latency, if you already happen to have a coaxial in the walls.

How are modern power line adapters latency wise? I’ve tried ones few years ago and it was horrific. Of course, it depends on the power lines layout, and this is an old building, but my experience was horrible: it was not only huge (500-1500ms) but also unstable. I ended up just adding ethernet drops all over the place (which is recommended way to do it anyway. even if you are leasing: no landlord would object you spending money to improve the space)

1 Like

Been using powerline adapters for a good 10 years now with almost no issues. They run excellent if your mains wiring is in good nick.

Yea true I could’ve run some proper cat6 from the start - really only need to go through a single wall (2 plasterboards) to reach the router, do it properly with back box and face plate etc., but just couldn’t be arsed since the powerlines worked so well. :slight_smile:

Initially, my old Zyxel pair would get me solid 1ms pings in command prompt, but after a few years I’d need to manually reboot it once every 2 or 3 weeks. Then one failed.

So replaced it with a newer TP-Link pair and it’s been solid 24/7, no rebooting necessary, latency still in single digits (1-3ms) and easily handles the bandwidth of my lowly internet of 72Mbps. Though it establishes at ~500Mbps - so not quite the full wack - yet good enough for my needs, and simply solid.

Incidentally, while some houses may have it, those coax style connections are much less common here in the UK, especially these days.

1 Like

Thank you. Dono about the part about the uid or gid. I have set the docker mount to read write. i guess the -ignore-owner part, i add to the extra parameters in the docker?

No, to the restore command