Duplicacy_linux_x64_3.0.1: permission denied

Setting up Duplicacy in Docker via saspus/duplicacy-web and keep running into a permission denied error when trying to setup my storage connection to a bucket in B2.

Failed to start the CLI executable: fork/exec /root/.duplicacy-web/bin/duplicacy_linux_x64_3.0.1: permission denied
Failed to check the storage at b2://TESTHELPTEST: fork/exec /root/.duplicacy-web/bin/duplicacy_linux_x64_3.0.1: permission denied

Steps I’ve taken to troubleshoot:

  1. I’ve already done “chmod +x” on ‘duplicacy_linux_x64_3.0.1’ at /root/.duplicacy-web/bin/ and at /bin/ on the docker app config folder, but am still getting the same error.

  2. Via the GUI, changed Command Line Version from Latest to Stable. Note, it’s still running 3.0.1 as the current version.

  3. Attempted to setup the storage after making the above changes. Ran into the same error and restarted my container in hopes a setting would kick in after the restart.

Does the user that the duplicacy_web runs under (USR_ID:GRP_ID) have access to the config folder?

Post your docker run command, and output from ls -l duplicacy_linux_x64_3.0.1

Thanks for the heads up on my USR_ID, that was the issue, it didn’t have access to the config folder.

Issue resolved!

Can you elaborate on how you resolved this issue with more clear instructions? I am unsure how to properly change permissions to give access to the config folder. Any help is greatly appreciated.

Thank you!

Hi Cam,

I know little of Docker, but i believe you need to set variables, e.g. on my unRAID installation, the instructions advise: To run Duplicacy as root set USR_ID=0 and GRP_ID=0

I did it but i still have the same issue.

Running backup command from /cache/localhost/1 to back up /backuproot/appdata
Options: [-log backup -storage storage -threads 1 -stats]
fork/exec /root/.duplicacy-web/bin/duplicacy_linux_x64_3.2.3: permission denied

Yesterday everything was fine:
Running backup command from /cache/localhost/2 to back up /backuproot/vm
Options: [-log backup -storage storage -threads 1 -stats]
2024-01-29 05:46:34.376 INFO REPOSITORY_SET Repository set to /backuproot/vm
2024-01-29 05:46:34.376 INFO STORAGE_SET Storage set to /backuproot/backupShare/duplicacy-storage
2024-01-29 05:46:34.396 INFO BACKUP_START No previous backup found
2024-01-29 05:46:34.397 INFO BACKUP_INDEXING Indexing /backuproot/vm
2024-01-29 05:46:34.397 INFO SNAPSHOT_FILTER Parsing filter file /cache/localhost/2/.duplicacy/filters
2024-01-29 05:46:34.397 INFO SNAPSHOT_FILTER Loaded 0 include/exclude pattern(s)
2024-01-29 06:16:37.009 INFO UPLOAD_KEEPALIVE Skip chunk cache to keep connection alive
2024-01-29 08:14:56.179 INFO UPLOAD_FILE Uploaded Macinabox Monterey/Monterey-opencore.img (157286400)
2024-01-29 08:14:56.179 INFO UPLOAD_FILE Uploaded Macinabox Monterey/macos_disk.img (274877906944)
2024-01-29 08:14:56.179 INFO UPLOAD_FILE Uploaded Ubuntu/Ubuntu/vdisk1.img (274877906944)
2024-01-29 08:14:56.179 INFO UPLOAD_FILE Uploaded Windows 10/vdisk1.img (274877906944)
2024-01-29 08:14:57.098 INFO BACKUP_END Backup for /backuproot/vm at revision 1 completed
2024-01-29 08:14:57.099 INFO BACKUP_STATS Files: 4 total, 786,582M bytes; 4 new, 786,582M bytes
2024-01-29 08:14:57.099 INFO BACKUP_STATS File chunks: 579703 total, 786,582M bytes; 45990 new, 232,420M bytes, 145,529M bytes uploaded
2024-01-29 08:14:57.100 INFO BACKUP_STATS Metadata chunks: 22 total, 42,465K bytes; 17 new, 41,185K bytes, 3,306K bytes uploaded
2024-01-29 08:14:57.100 INFO BACKUP_STATS All chunks: 579725 total, 786,623M bytes; 46007 new, 232,461M bytes, 145,533M bytes uploaded
2024-01-29 08:14:57.100 INFO BACKUP_STATS Total running time: 02:28:23

Does it have execute flag set?

I don’t know, where can I see it?

In bash

[ -x path/to/duplicacy] && echo "File is executable" || echo "File is not an executable or does not exist"


ls -l path/to/duplicacy 

And check if it has x flag set for the user and group. While at it make sure it is readable by a user duplicacy is running as.

Or just set that flag anyway:

chmod +x path/to/duplicacy

Or delete the executable and let duplicacy_web download and configure one again.

I’m using unraid as an OS and Duplicacy inside a docker container, how do I find this user and give him permissions?
In the OS I have only 2 user, root and my personal one.

This is what i get with the command you gave me:

I also tried your second command, it gives me the same error trying to create a new storage

Path to duplicacy I meant path to duplicacy executable in the bin folder.

Is duplicacy container running as root? Or what user?

Yes, the container is running as root.

ls -alt /mnt/user/appdata/Duplicacy/bin

This is what i get:

Hi, try to do

chmod +x /mnt/user/appdata/Duplicacy/bin/duplicacy_linux_x64_3.2.3
1 Like

Now it works, thanks to y’all.

Odd that it was problematic. I didn’t have to muck around with that when i installed my docker Duplicacy. I’m not running mine as root, but that fix means it wasn’t even executable. Weird.