Duplicacy to locally connected USB drive

Hello all!

I run Duplicacy in an unraid docker container. I have a USB drive that I manually connect once a month to do offline backups.

For some reason, duplicacy only runs this backup at around 600 KB/s. It starts at a few mbps but slows down. I can do a local copy from the server to the USB drive in around 200 MBPS so I know that the USB controller is working correctly and that Duplicacy isn’t saturating the hard drive.

I’ve tried playing around with the threads but I can’t seem to figure out why it’s so slow… Any suggestions?


Sequential transfer speed is irrelevant. Check iowait on your disk during backup — aka seek latency.

There could be other issues — does the disk enclosure support UAS? What’s the host? CPU? Ram?

You may want to start with running duplicacy benchmark

Thanks for the reply.

In unraid, I am not quite sure how to check disk latency, only reads and writes.

For the USB disk, it’s just a simple USB drive enclosure that holds an 8 TB single hard drive.

I haven’t used the Duplicacy CLI yet. I’ve tried opening a CLI console directly into the docker container but it doesn’t appear to recognize any dupliciacy commands. Is the CLI automatically installed when using the docker container from saspus/duplicacy-web?

For the host, I am running an AMD Ryzen 1800x with 16 GB’s of RAM. Nothing super crazy.


You would need to find a way to look at IOPS on your main array and the usb drive. I’m not familiar with unraid.

There are few possibilities:

  • reading data from your source can be a bottleneck if you have a lot of small files.
  • writing data to the usb hdd can be slow: depending on chunk counts, filesystem used, and disk performance.

Duplicacy benchmark will first encode chunks and then copy them — this may help to rule out your usb drive performance.

This is how to run CLI with webui config: CLI and WebUI - why don't they know each other? - #3 by gchen

Ideally, find out how to check disk IOPS on your main array and usb drive during backup — this will be definitive. There must be some community plugins to do that, if this functionality is not shipped by default — I would be very surprised if it isn’t. That’s a storage device — of course knowing iops is the top priority