Duplicacy-Web Docker fails

I’ve made quite a mess here…

My present problem… I’m running duplicacy-web as a docker container on Synology using saspus/duplicacy-web mini.

When I opened this tonight I couldn’t backup as it said I was on a different machine than the one registered (I was on the only machine that runs Duiplicacy). In trying to sort this out, I saw a “listening” entry… thinking that was the problem, I edited that using my NAS IP. so

Now the docker container fails with…

Can't start the web server at listen tcp bind: cannot assign requested address

Q1: How do I undo that?

Assuming that I get back to the web interface that shows all my schedules and backups etc., how do I fix that so it sees the host name I’ve been using… the one associated with my license?

Thank you!

OK… I have the listening issue resolved.

But I’m in trial mode and I haven’t figured out where the host name is set on the Web GUI.

When I tried to “reactivate” it tells me the license is associated with a different host. However I don’t see a host name anywhere on the Web GUI.

Thanks for your help!

Hostname is assigned to docker container by docker, see --hostname argument.

There are also some issues with managing and activating trial licenses, according to a recent ports, maybe you are hitting those.

Edit settings.json under /config folder.

I don’t see anything there that has helped. My license expires on April 3.

I tried renaming licenses.json, restarting the container, and then re-entering the license and I still get the already in use window.

My hostname= is the same as that on my license registration page. I have never touched that.

I am dead in the water. Anything I’ve missed?

Do I need to manually re-run docker-compose? I tried a “reset” (under Synology) without improvement.

The host name as seen by Duplicacy isn’t necessarily the actual host name of your Synology box. It can be set in the docker file. So all you need to do is to look at the docker file to see what the host name is set to, go to Log in required to change the associated host name, and then re-activate the license.

The error message should also tell you what the current host name is.

In the file /docker/duplicacy/saspus-duplicacy-web-compose.yml
There is

Where ABCD is the same Host under my license.

Next I log into my duplicacy account and change the host to ABCD123, and then edit the YML file to ABCD123. I start the container using the Synology Docker GUI, and still it says expired. If I try to enter the key in the container WebGUI… its says

How can that be? It’s a new host never used before.

There is no error in the log except the “Failed to download” message.

What am I missing? Thank you.

“can’t be activated on duplicacy-web” → the host name is “duplicacy-web”, no ABCD.

“can’t be activated on duplicacy-web” → the host name is “duplicacy-web”, no ABCD.

That was just an attempt to change host registration. My license host is identical to the docker host.

Here is YML (without mappings)

Just change the host on the licenses page to duplicacy-web and you should be able to reactivate the license.

I don’t know why it is duplicacy-web but maybe the container_name overwrites hostname?

See previous yml screenshot. Docker matches license host. I’ve changed both numerous times. It is always expired.

What I meant is, log in to https://duplicacy.com/licenses, click the link under the Host column and change it to duplicacy-web.

I have it up now. I gave up on the original docker container.

Using Portainer, I entered the YML file as a stack. Now it is authorized.

It’s not clear what the problem was, but I suspect that the host info in the YML file was not being read and therefore the license could not be verified.