Duplicacy Web Dropbox Issue

So, I’ve been waiting for the Duplicacy CLI to be updated to support the long lived token for Dropbox and I see it was finally added a week ago with v3.0.1.

I have verified that the Web-UI grabs the latest linux binary (I am using hotio’s docker container for Duplicacy WebUI)

However, when I try to add Dropbox storage via the Web-UI, I enter my access token, and it will successfully enumerate folders which I can select, but when I click Continue, and it does the storage check, I get this error message:

Not sure what do to from here as it won’t let me add the storage to I can run my job schedules that are currently disabled for this storage provider.

Here is the logs messages from the duplicacy_web.log when I try this:

2022/10/13 13:59:58 IPADDRESS:63522 POST /info_storage
2022/10/13 13:59:58 Running /app/.duplicacy-web/bin/duplicacy_linux_x64_3.0.1 [-log -d info -repository /cache/localhost/all dropbox://Backup]
2022/10/13 13:59:58 Set current working directory to /cache/localhost/all
2022/10/13 13:59:58 DEBUG PASSWORD_ENV_VAR Reading the environment variable DUPLICACY_DROPBOX_TOKEN
2022/10/13 13:59:59 ERROR STORAGE_CREATE Failed to load the dropbox storage: Can't create storage directory: No access token returned
2022/10/13 13:59:59 ERROR STORAGE_CREATE Failed to load the dropbox storage: Can't create storage directory: No access token returned
2022/10/13 13:59:59 Failed to check the storage at dropbox://Backup: Failed to load the dropbox storage: Can't create storage directory: No access token returned
1 Like

Unfortunately the web GUI doesn’t accept the long-lived refresh token from Dropbox. I’ll release a new version next month to support it.

1 Like

Any updates on this?

Ditto here. Is this coming soon? I’ll be buying a license just as soon as it is!!

Sorry I haven’t been able to work on a new web GUI release, so it is unlikely it will be out this month. I’ll try to get it done by next month.

Ok! Looking forward to the release. Thanks for your good work

because of this issue, I’m already a month without backups… Is there any workaround until new release? This is quite dangerous for me, as I’m now unable not only to take new backups, but also restore old data in case of any issue.

Are you not able to use the cli binary in the mean time? It should use the same configs as your web. Then you just set a scheduled task / cron job and let it go

Thanks for working on a solution for the WEB GUI. In the mean time is are there steps we can take to get it working through CLI? If so could you provide them?

Bumping this.

I’m also getting the same error, is there a work around that can be done temporarily?

I’m sure there’s a way you can use duplicacy cli with the same storage config from the web-ui and setup a cron job or something in the mean time since the latest CLI release supports the long-lived token.

What I’ve been doing is I have duplicacy take a nightly backup to local storage, and then once a week, I’ll use rclone to copy it up to dropbox.

Unfortunately, I’m setting this up for a client, and I can’t show them CLI. They need to be able to check download status via the web interface.

@gchen Chiming in as well. Just bought a commercial license expecting to be able to use Dropbox for my client. Still doesn’t work.

Is there any update on this?

I second this. I’m already two months without backups because of this, while I’m paying customer of Duplicacy. I tried to be patient with the promise of new release soon and I’m happy to support the development, but paying for not working product is quite hard to accept :frowning: .

Could the be prioritized or can we at least get some ETA, so that I know whether to migrate to some other backup software?


Also as a paying customer (three licenses), finding this really inconvenient. I will be considering other solutions until I hear some kind of update.

What is also concerning here is that the cli binary was updated with this fix, but the web UI wasn’t even thought of until a forum post was made.

1 Like

Yeah I’ve been having this issue ever since I started using the app months ago, I was sure I was the one doing something wrong but then I noticed people on forums stating the same thing. I hope the web UI get some attention soon on this part as I renewed my account with black friday.

I saw @gchen had posted that he was planning a Jan release for the web UI.

Personally, I can’t wait that long.

@pairofcrocs where did you see this? A January release would be great if true (at least for me)