Duplicacy Web Dropbox Issue

I thought that meant November 21st :skull:

1 Like

@gchen Is there any way we can get some sort of update.

I really don’t want to consider different solutions, as I’ve been happy up until now.


It’s been a good run Duplicacy…

After months of no backups, the dev seemingly has given up on a core feature that we’ve paid for, I have to make the switch.

I understand these things take time, but you said in October that we’d get a new version in November. All I wanted was some communication of what was happening.

I suggest that you remove that you support Dropbox until this issue is (hopefully) fixed.


Responding to @pairofcrocs. Whilst I don’t need DropBox as my primary backup destination, I would agree that handling of this is sending out some bad signals:

If this project was free and open source, people would be understanding that the project can’t always take primary developer time; or even that people can submit patches themselves

But this is a closed source project, charging a recurring fee. If people aren’t paying for developer time and reasonably active support, what are they paying for?

I’ll be continuing to use the project for now, but I think devs should be aware that it looks a bit like they’re happy to take the money, but not to provide the service that should be expected along with it

1 Like

I apologize for the delay in the next release of the web GUI. I’m working on multiple projects and sometimes unexpected issues on one project make it difficult to allocate time for other projects. However, In the long run I prioritize all my projects equally. It is challenging to adhere to a strict schedule but if I promise something I’ll get it done eventually.

By no means I intend to just take your money without doing anything in return. Please let me know if you’re not satisfied with the slow progress, or anything else, and I’ll refund the money.

Hi @gchen. Thanks for your response. I’m sure no-one wants to feel like a nag here! Seems like this is critical to @pairofcrocs, whereas for me, I just hope that I don’t run into the same problem when something that’s primary to me comes up :crossed_fingers:

Otherwise, this seems like a nice piece of software, better than plenty of alternatives, and that I’m happy to pay a reasonable price for. I just hope maintenance load is sustainable

Hi everyone,
while I’m looking forward for the fix, I found a workaround and I have it working for two weeks now. Use on your own risk, however.

Consider we now have not working storage named “dropbpox” pointed to dropbox://something folder.

  1. Backup duplicacy.json configuration file located in .duplicacy-web/ folder.
  2. Go to Dropbox for Duplicacy (I’m not sure where I found the link, but it’s a different site than
    the one listed in the how-to, this one does not end with “.html”) and obtain “Dropbox refresh token”
  3. In duplicacy web, go to Storage > Add new Storage > Dropbox. Paste the token. Directory selection won’t work (“Failed to list the directory ‘’: invalid_access_token/”), but you can just paste here the same value you have in your current dropbox storage (for example dropbox://something). Click Continue and configure the storage in the next step. Configure it the same way as your current (not working) dropbox storage, except for the name (which will be for example “dropbox-new” - we cannot use the same name as we already have). Save.
  4. Stop duplicacy.
  5. Go to duplicacy.json. In storages section should now be two records - one for the old one Dropbox storage ("name": "dropbox"), one for the new ("name": "dropbox-new"). Make sure the setting except for name and credentials are the same (for example they both have “encrypted” set to true). Now change the “name” value of the old repository (this is not possible in the GUI, so it must be done in the json file) for example from “dropbox” to “dropbox-old”. And similarly change the new repository from “dropbox-new” to “dropbox”.
  6. Start duplicacy. Ale current schedules pointed to repository named “dropbox” should now be pointed to the repository with the new token. You can try running the schedules.
  7. If everything is working, remove the “dropbox-old” repository.

Not sure how link this will keep working, maybe the token will expire, but I at least as a temporary workaround I have working backups for now (and if needed, I can manually repeat these steps and re-add the storage with new manually generated token).


Hi, is there any update to this on the Web version? I just recently bought and was hoping this would be fixed soon. I have a workaround where I have Dropbox runniing in docker to a local folder, and I just copy it into that folder. But that docker image is flaky and stops working randomly, so I’d like to see this working to bypass that.

A new release of the web version should be out the end of this week or next week.

1 Like

Hi, any news about new version ?

It looks like the new version got pushed to the latest branch and docker updated.

So I tried it out, and got the access token. But when I need to select a folder, it is empty and I cannot proceed.

Don’t seem to be having much luck here either. Browsing doesn’t work as above, but trying a few manually entered paths and hitting Continue still results in

Do you have any directories under App/Duplicacy?

If you want to manually enter the path, it should be just Foo instead of App/Duplicacy/Foo. Also, make sure the CLI version is 3.1.0 – older versions can’t access the storage with a refresh token.

My set up:

  • Docker
  • I needed to select Latest and restart in order to get 3.1.0:

Screenshot 2023-02-27 at 14.05.31


  1. Deleted the previous Duplicacy app in Dropbox to clean up
  2. Create a new access token from Dropbox Token for Duplicacy
  3. Created a folder called Storage inside (Dropbox/Apps/Duplicacy/Storage)
  4. Add a new storage in Duplicacy (see below, browsing works ok):

Screenshot 2023-02-27 at 14.00.16

  1. Unlike the other poster, I can browse for the Storage folder I created:

Screenshot 2023-02-27 at 14.01.55

However, it still doesn’t work:

Screenshot 2023-02-27 at 14.05.14

Hope you can help

Unlike @sites I do not have any folder in Apps/Duplicacy. I guess this doesn’t solve my use case then, because I do not want my backups stored in Apps/Duplicacy, I want them in /Backups where I already centralize backups from multiple sources.

@raymond.bennett I’m not a very active user, but it looks like you’ll have to use /Apps/Duplicacy, because this is just how the apps API segregates files. You could probably just create a link to it from your desired location

I’ve only got a dir in there because I created it, but the Duplicacy selector seems to assume you select a subdirectory. That’s fine in my case, but there’s still the prob above

@sites you’re still running web GUI 1.6.3 – the dialog says Access Token rather than Refresh Token.

Ah great! You are correct. I switched to the latest tag for the Docker image, and now getting 1.7.0, and can happily report everything seems to be working correctly!


Sorry for my ignorance. Where does one get the latest 1.7.0 version? I am using the Hotio container and it is still at 1.6.3. Thank you.

@gchen do you need to set your app in Dropbox to only allow access to Apps folder? I don’t find this an ideal solution. Could you have 2 apps, one for full dropbox access to allow the folder to be placed outside of the apps folder, and this version that restricts it for those who are more concerned?