Duplicacy Web Edition 1.0.0 is now available

A post was split to a new topic: Cannot restore single file

I would like to note that using this configuration, I have found that the service does not work fully with scheduled jobs after a restart or shutdown is effected in CentOS. Any scheduled jobs will failure after a full system restart and refuse to run. They have to be “kickstarted” with an initial manual start. After this, though, the scheduled jobs will run automatically without user initiation until the next system power cycling event occurs.

3 posts were split to a new topic: Transfer licenses to web edition?

A post was split to a new topic: Check files after upload

4 posts were split to a new topic: Duplicacy in Ubuntu linux container

Adapting this may fix the issue with Duplicacy not self-invoking a job after a reboot. (Update: I confirmed yesterday that it worked for me, at least.) The issue is Duplicacy may start before the network interfaces are fully loaded. Thanks, @lonich.karoly!

By default the systemd service starts and runs with / as the working directory. So duplicacy-web installs its configuration, logs, etc. under /.duplicacy-web.

Adding WorkingDirectory=/root/ in the [Service] section allows for the working directory to be somewhere else: in this case the working files will now be found under /root/.duplicacy-web.

1 Like

Do you plan to make the Web Edition available for FreeBSD also in the future?

1 Like

That didn’t work for me; I have to set Environment="HOME=/root .

Is there, or will there be, a Windows x86 (32-bit) version?

I’ll add a win32 build when releasing the next update.


q: why would anyone want to use win 32bit?

@gchen Thank you!

@TheBestPessimist I built my HTPC (home theater PC) 12 years ago. Back then, most things were 32 bit; x64 was just starting to become a thing. There weren’t x64 drivers for some of my specialized A/V hardware, as I recall. My HTPC has an x64 CPU, so I could upgrade my it to x64 Win 10. But that would involve a clean OS install and reinstalling all my software, including photo viewing and editing, video and audio viewing and editing, sound card, video card, serial port emulation, in addition the the more “normal” software items like web browsers, Adobe reader, etc. Installing and configuring all that software would require many, many hours of work, with no sure guarantee of eventual success.

So, the reason I’m using 32 bit OS on this particular PC is because it’s already there. All my other, newer, PCs are x64 of course.

1 Like

Two things. First, since the post right above mine requests a 32bit version for Windows, I would like to request a 64bit version for ARM Linux. My own backup server has been an ARM 64 board since switching from another backup system last year. With the backups I pump to Wasabi, I believe a 64bit version would be more efficient and faster than the current 32bit version which, even with 6-8 threads, can take days for a legit backup.

Second. There hasn’t really been anything that I’m able to see with Duplicacy supporting OneDrive Business as a storage. I tried several times with this newest release, but when I follow the link from the Duplicacy web site, the Microsoft site reports my user is not recognized. I believe this is because it is a OneDrive Business, not personal, account. Is there any hope for it being supported soon?

A post was split to a new topic: Config directory keeps getting created under Debian

Microsoft has an annoying habit of taking two entirely different products and naming them exactly the same, except one gets ‘business’ at the end. Same thing with skype.

Not my biggest irritation about them by far, but damn bothersome nonetheless.

A post was split to a new topic: Web-UI binary for Free-BSD

Can I use my preexisting license or does it need a new license?

I think u can use existing. Why not give it a try and see how it works?

3 posts were split to a new topic: Trying to run saspus/duplicacy-web docker