Duplicacy Web Edition 1.8.1 releases


QNAP packages:

Synology packages:

1.8.1 Changes:

  • Fixed a bug in leap year calculation
  • Fixed a typo in storage selection dialog for samba
  • Upgraded Go to version 1.20

1.8.0 Changes:

  • Added support for the new Samba backend
  • Added the zstd option when creating new storages
  • Support multiple selections when restoring files/directories
  • Fixed a bug where files starting with @ were not restored when selected
  • Fixed a bug in the Google Drive storage where a shared drive can’t be found when there are more than 10 drives
  • Modified the schedule start times to use all capital letters for AM/PM
  • Upgraded Go to version 1.19

Hi thanks for your work. I will update on my Windows Desktop this weekend :wink:

1st bug :slight_smile:

When adding à samba share, when i click the icon to browse at the right of “Share” it talk about " Select a Strorj Bucket as the storage" and not samba share, and it fail to browse directories, it do nothing when i click directory.

What samba server are you running? The issue here was that your samba server returned the full path \\desk.home\data including the server as the share name. On two samba servers I tested only the share name data was returned.

As a workaround you can edit the Share input to remove the server name. This should allows you to browse directories.

Oh, ok i see, it is my mistake.

I use Debian 12 default repository samba backend.

With this configuration that works, browse button works and i can select directory and it take it,still talks about “Select a Strorj Bucket as the storage” but it works

QNAP qpkg, please.

BTW, the version available in the QNAP AppCenter is still 1.4.2.

I would love to get the QNAP installer as well. Thanks!

1 Like

Thanks for the update, been waiting for this. I didn’t think my data would be all that compressible, but I used this version to create a new compatible storage with zstd-best enabled and copied an existing repository over. It’s slashed almost 23% off my storage usage! Other peoples experience may vary, I have virtually no media files, but this was significant to me.

Because I’m throttled by network speed (everything is 1 thread, capped at 100mbps) the extra resource usage is negligible. Under 500mb RAM, single digit CPU utilization.

This will delay the need for additional storage for quite a long time. Thanks again.

1 Like

11 posts were split to a new topic: How to use recent duplicacy_web release in a docker container

Many Thanks for the new Version!

Just thought I’d mention, the version available on the download page is still the older 1.7.2…

@gchen Any ETA on a package for QNAP?

1 Like

I added links to QNAP and Synology packages.

Still only 1.8.0 listed on the download page @gchen.

I am having some trouble downloading the R1000 synology release. It is flagged by windows defender as a trojan.


I see there are checksums available for the main packages but I cannot find any for QNAP/Synology so I am not comfortable adding an exception. Can you check this / provide advice? None of the other downloads are prohibited by Windows Defender, only the R1000 release.

It is a false alarm. VirusTotal finds nothing: VirusTotal

The R1000 package was built with DSM 7.1 while all others were DSM 7.0.

I get “the certificates for this application are expired” using duplicacy_web_qnap_x86_64_1.8.0.qpkg on QNAP TS464. It runs fine though.

same, it’s signed with a certificate that expired in september.

I just updated to v1.8.0, excited to try out the ability to select multiple folders/files to restore. Unfortunately, I cannot get it to work on any desktop browser (I’ve tried it in Firefox, Chrome, and Edge. I am unable to select even a single folder or file. Clicking on the filename in the list does nothing (I can expand folders by clicking on the folder icon). On a whim, I tried it on my phone and the selection does work properly there (I see the check mark next to each folder/file I’ve selected).

Anyone else having trouble with this? Is there some secret I’m missing? :grinning:

Can you open the browser developer console to see if there is any error (F12 on Chrome)?