Duplicacy Web Edition - license needed?


#1

Hi!

I tested the command line version of Duplicacy some time ago but ended up continuing using Crashplan because I still had a subscription. My subscription is expiring in a couple of weeks and I don’t want to renew because after the transition to the Small Business thing it would cost me twice as much.

So I am now testing Duplicacy Web Edition using Wasabi for the storage (which would cost me half the price of Crashplan), and I really like what I see.

One thing that is unclear to me is, do I need to purchase a license? In the backup page of the web app there is a link “Trial” but it’s pointing to the same page. I want to use this to backup my home iMac, not for business. If there’s a license or subscription to purchase, how much would it cost and how would I purchase it? On the main website I can’t see any mention of this Web Edition (perhaps I am blind…).

Thanks a lot in advance for the clarification.


#2

I think it’s the same as the regular personal license.

If so, it would be the prices shown on this page. For a single computer it says it would be $20 for the first year and $5 for each subsequent year. Licenses for additional computers cost less.

I’m guessing there’s no mention of the web edition on the main website because it’s not released yet; but I purchased a personal license for the web UI and it accepted the license just fine.


#3

Thanks for your reply, I will purchase a personal license then. Once I have it, how do I enter it in the Web Edition? I don’t see a setting for this in the settings page. However I see that there is a file named .duplicacy-web/licenses.json in the repository, do I have to enter it there? Thanks.


#4

I don’t know why, but somehow I tried again clicking on the “Trial” link and it showed the form to enter the license. Weird.


#5

I do have a Duplicacy GUI license, but I am currently using the Web edition. After a couple of weeks I now get the error “Invalid or expired license” at each scheduled backup. But I don’t see an option to enter my license code. Any advise?


#6

You can try deleting the license file, .duplicacy-web/licenses.json it will generate a new one, then follow previous comment about clicking the trial link


#7

I have tried that already, but this may be the problem - a new license is not generated when restarting the web-gui.


#8

Did you try to click the Trial link and then it will let you enter the license code?


#9

Okay, after looking through all the options again I saw the relevant option. In case anybody is as blind as I am: It’s in the Backup tab, then next to localhost in my case it said “unlicensed”. Clicked on that link, entered license, and now its registered as “Personal”

Can I suggest to move this to a more obvious place and make it more prominent? Perhaps under Settings?