Failed Backups and Failed Check - 'Connection Reset by Peer'

I’ve been running a regular daily backup to AWS S3 ( Simple Storage Service) and all has been fine until a few days ago when one of the the backups started failing with “reset by peer” error messages. I thought it may not have been coincidental with an upgrade on my internet to 900Mb Fibre, so I dropped my threads to 4 and I added -d to global options. I also ran a check with the same parameters. Same error. Both log files attached.
Check_log-4 threads.txt (314.7 KB)
backup_log_4_threads.txt (2.0 MB)

Does anyone have any idea how to resolve this? Thanks

1 Like

Well, I am not sure or convinced that reducing the # threads was the solution, but nonetheless today the backup completed normally. Yay!

Success more by good luck than good judgement I think!

I don’t think threads have anything to do with this. Maybe there was an intermittent issue server side and is now solved.

Put back 10 or 20 threads. It shall not matter with AWS.