Failed to list the revisions: Error: Request failed with status code 405


I’m getting this error when I try to restore:

Failed to list the revisions: Error: Request failed with status code 405

I’m trying to restore from GSuite

Please help, thanks!

Do you keep getting this error every time?

yes, though it seems to only be affected backup IDs with a large number of revisions, the ones with smaller numbers of revisions still load

Does the affected backup ID contain special characters? How many revisions does it have?

It has an underscore in it. How can I check the number of revisions?

This is what my storage page looks like

I suspect that there is one revision file causing this error. To find out which revision it is, go to ~/.duplicacy-web/repositories/localhost/restore/.duplicacy/cache/snapshots/backup_id and list the revisions there. The revision in question should be the smallest one that doesn’t show up there.

Once you identify such a revision you can verify it by running:

cd ~/.duplicacy-web/repositories/localhost/restore/
~/.duplicacy-web/bin/duplicacy_osx_x64_2.7.1 list -storage storage_name -r revision

that folder appears to be empty (the .duplicacy folder)

Sorry it is actually ~/.duplicacy-web/repositories/localhost/all/

I’m running this off of the saspus/duplicacy-web container. any idea how to interact with all this?

It’s worthing noting that this happens with all backups with a good number of revisions, not just that one I was having an issue with. Would this be fixed by purging some more, is it a network thing or something else entirely?

You can open shell into the docker and run these commands:

cd /cache/localhost/all
/config/bin/duplicacy_linux_x64_2.7.1 list -storage storage_name -r revision

So I never managed to fix the issue in duplicacy web, I even cleared the cache, relisted with the command line, and then tried again in web. Now that I can access the command line though, I successfully restored from there - I think it’s an issue with gSuite somehow, but I managed to workaround so, all good!

Can I asked how you fixed it? Having the same issue, same setup, more here.

Hi! I cleared the cache, then relisted from command line, then restored a specific version via the CLI.

However, due to this issue I was reticent to continue with duplicacy and have actually stopped using it, which is quite sad! @gchen I’d look into this, seems to be an API issue when revisions get to be too many on Google Drive (maybe timeouts? rate limits? sorry I can’t be of more help on that side of things!)

Thanks for the quick reply! I’m in the same boat myself, have been happy with Duplicacy this far but but this is leaving me a bit uneased :neutral_face: