Failed to save password to C:\Users\.duplicacy\keyring

Trying to use Duplicacy today with Google Drive and got the following error:

Screenshot here:

Does the directory C:\Users\.duplicacy exist? Do you have the permission to create a file under this directory?

I had the same issue but I did solve it:

If I tried to create a folder from the file explorer as administrator beginning with a “.” I got the error “You must type a file name.”

If I ran the cmd prompt as admin I could run “mkdir /Users/.duplicacy” and it would create the directory. I could then right click on the folder in explorer and change the permissions to my user could write to the new directory.

After that Duplicacy could write it’s configuration. Duplicacy should really have the ability to ask to be run as administrator and then do these tasks. Or at worst have some dialogs to help the user do this manually. I’m assuming many Windows users would run into this problem.

1 Like

Thanks. That is helpful.

@Henry Bakker Thanks that solve my problem as well :slight_smile: