GatherWriteMetadata didn't finish properly

gui
backup

#1

“Backup operation returned an error:
ERROR Shadow copy creation failed: GatherWriteMetadata didn’t finish properly”

Any ideas?

I checked the bucket in B2 and nothing was loaded so it failed.

Log:

2:00- Command duplicacy -background -log backup -stats -threads 4 -vss
2:00- Storage set to b2://BUCKET
2:00- No previous backup found
2:00- Creating a shadow copy for DRIVE
2:01- IVssAsync is pending for more than 60 seconds
2:01-
2:01- Shadow copy creation failed: GatherWriteMetadata didn't finish properly

OS is Windows Server 2012 R2. Drive has about 300gb on it (its a 2TB virtual disk [128gb SDD + 2TB pool])


#2

Can you try this build: https://acrosync.com/duplicacy/duplicacy_installer_win64_2.1.1.exe

For this build you can set the VSS timeout to any value by adding a registry value under HKCU\Software\Duplicacy\Job\ShadowCopyTimeout (where is the index of the backup job). This registry value should be a string.


#3

I’m not super literate in services, etc- so stay with me!

I uninstalled the original build that I downloaded from the website (just using the uninstall wizard).

Then I run as admin to install the build you sent me a link to. I click install for all users… and I get an error:

Error opening file for writing:
C:\Program Files (x86)\Duplicacy\DuplicacyGUI64.exe

Click Abort to stop install,
Retry to try again, or
Ignore to skip this file

I’m going to try and see if the service is still running even after the uninstall? But not sure.


#4

OK- so i was able to get past that error by stopping the service (I still can’t figure out how to uninstall it…) and deleting the Duplicacy folder with the .exe.

When I say install as service, it tells me it’s already installed tho…

Anyway, I get the new 2.1.1 Beta 1 GUI to launch.

I don’t see where I can modify the ShadowCopyTimeout. Is that in the GUI or some command line?

I really want this solution to work…!


#5

You can run sc delete "Duplicacy Cloud Backup" in an administrator DOS window to uninstall the service.

I would suggest you test with the GUI version first to make sure it works before switching to the service.

ShadowCopyTimeout is a registry value you need to create under HKLU\Software\Duplicacy\Job<n>. I When you run the registry editor you can find this path that corresponds to the particular backup job for which you want to change the timeout.


#6

I’m getting the same timeout error and I’m assuming the possibility to set the timeout is part of the 2.1.1. release but I can’t find the right place to put the registry value. I don’t have a ...\Job\ folder. Only ...\Job1\, ...\Job2\, and ...\Job3\ but none of these are for the repository where I’m getting the timeout error.

How do I go about this?


#7

Did you look under both HKLM\Software\Duplicacy and HKCU\Software\Duplicacy? Depending on how you installed the program (for all users or for current user) Duplicacy may pick one of these to store the registry values.


#8

No ..\Job\ folder in either of these.

image

image

And none of these ..\Jobx\ folders seems to relate to the repository in question (D:\) . However, I noticed that when I select the Duplicacy folder under HKCU\Software\Duplicacy, I noticed that the Repository value shown is D: But I’m still not sure where to put the registry value and I think it would help a lot if that value was already there and I’d just need to change it.


#9

In version 2.1.0+, the repository is saved to HK{LM,CU}\Software\Duplicacy\Jobx\Repository. Earlier versions only supported a single repository which wass saved in HK{LM,CU}\Software\Duplicacy\Repository (and didn’t support the new ShadowCopyTimeout option).


#10

I am running the latest version of duplicacy (CLI) but my repository (or one of them) is saved in HKCU\Software\Duplicacy\Repository. So that doesn’t quite match what you’re saying unless the repository entry is a relic from some eralier version but then the question would remain: where is the current one and - above all: where should I create the ShadowCopyTimeout registry value for that repository?


#11

Sorry I thought you are running the GUI version. For CLI there is a -vss-timeout option:

   -vss-timeout <timeout>	the timeout in seconds to wait for the Volume Shadow Copy operation to complete

The CLI version doesn’t deal with the registry setting at all.


#12

So this has been fixed, right?