How to recover from failed password change

I tried to change the storage password using the duplicacy password command. The unencryption using the old password went fine. However, the new password was rejected as being too short. The command quit with a message about saving a temporary copy in config. Config appears to be an unencrypted copy of the file. Backup now does not work. I get a message saying the storage is not initialized. How can i recover? Thanks!

You can use the unencrypted config file to create a second storage, and then create a third storage that is bit-identical with the second storage but encrypted with a password:

mkdir /tmp/storage
cp .duplicacy/config /tmp/storage
duplicacy add old test /tmp/storage
duplicacy add -e -copy old -bit-identical new original_repository_id original_storage_url

Now you should have 3 storages in the .duplicacy/preferences file, with the first and the third pointing to the same storage url. You can manually edit this file to keep only the first one.

Thanks. That worked fine to get my Linux machine going again, and I never would have been able to figure that out myself.

I need a bit of additional help. I have a second machine (Windows 10) running Duplicacy web edition backing up to the same storage using a bunch of ID’s that are different than what the linux backup uses. When the Linux machine stopped backing up due to the password problem, backups on the Windows machine started failing too, and they still do. How can I fix that?


This is likely caused by the web GUI on your Windows machine still using the old password. Deleting the storage and then creating a new one with the same name should fix it.

That worked. Thanks.