How to reset host keys? Can't add new SFTP storage

I recently reset my Synology NAS and now the host keys have changed, as has the IP address. When adding it as a new sftp storage I see the error “Failed to create the sftp client: ssh: handshake failed: The host key for ‘[xx::211:xx:fe78:xx%en0]:22’ has changed” (the storage’s user, IP, directory etc. are the same as before, then I changed the IP, but I still get the same error)

I am on MacOS using the Duplicacy Web Edition. Although I have reset my ~/.ssh folder and removed the known_hosts this problem is preventing me from using Duplicacy (I am in a testing phase, and trying it out with all my NAS boxes +Backblaze).

Which file do I need to edit to make Duplicacy forget the old storage IP/MAC/hostname?

I am also having a similar problem on a Thecus NAS; that sftp storage is not accessible any more either and I can’t figure out how to change the storage details (IP/hostname/MAC) through the web GUI.

The host keys are stored in ~/.duplicacy-web/repositories/localhost/all/.duplicacy/known_hosts.

Many thanks! Didn’t think to look under repositories, was looking for ‘storage’ and under ~/Library

:-/