How to upgrade to Web UI 1.6.2

There are no instructions on upgrading in the Web UI Guide https://duplicacy.com/guide.html. A quick search on “how to upgrade web ui” showed a couple of confused threads, but nowhere do I find a clear step-by-step set of instructions.

Anyway, I forged ahead without instructions. I didn’t recall specifically if it’s needed with Web UI, but I ran the 1.6.2 installer as admin, to make sure the service got installed. It completed, complained that the service was already installed, and “finished.” Surfed to the 127… Web UI IP and it’s still version 1.5.0. In Program Files/Duplicacy Web Edition are two exe files, 1.5.0 and 1.6.2. Can’t delete 1.5.0 - “The action can’t be completed because the file is open in Duplicacy Web Edition.” What?

Seeing the …Uninstall.exe in the folder, I realized I didn’t uninstall 1.5.0. I ran the uninstall, it “finished,” but trying again to install 1.6.2 produced the same result. I noticed that the Uninstall process didn’t change any of the files in Program Files/Duplicacy Web Edition. I rebooted and still can’t delete the 1.5.0 exe.

Rummaging around some more, I notice that there’s a DuplicacyWebEdition folder in AppData/Local, which contains only a 1.6.2 exe, among some other files that are duplicated in Program Files/Duplicacy Web Edition. Why are these files in two places? Will I get different results if I run the uninstall.exe from AppData?

This whole thing is quite confusing. I’d just like to upgrade to 1.6.2 and it shouldn’t be this difficult. I will be grateful for some assistance.

If you install the web GUI for one user, then it is installed under AppData/Local. But if you install for all users, then it is installed under Program Files.

It looks like that 1.5.0 is still running as service. In this case you’ll need to run the uninstaller as administrator to uninstall the service. If you’ve already deleted the shortcut folder then you can remove the service manually in a DOS window (run as administrator) by running this command:

sc delete "Duplicacy Web Edition"

Thank you @gchen for your quick reply. When I tried installing the 2nd time I must have installed for one user, causing the Duplicacy directories in two places.

I ran the uninstall as admin and it removed the service and removed the Program Files/Duplicacy directory. I ran the install as admin, chose Install for All Users, and it installed in Program Files and installed the service. Duplicacy 1.6.2 is now running fine, and I removed the spurious AppData directory.

Please consider improving the Duplicacy documentation. The only official doc I found (the Guide) says only “On Windows and macOS, Duplicacy Web Edition is provided as installers. Installation is needed before you can start the executable.” There’s much more that should be said, such as running the installer as admin (installs as a service) vs. not as admin. Also there is no information on uninstalling or upgrading. There should be detailed instructions. Publish this info and there will be a lot fewer forum posts on these subjects.