Invalid or expired license 29 days left

Btw are you seeing this issue with paid or trial license? The trial behaves differently according to gchen comments above

Trial license. As noted, just started evaluating Duplicacy and want to verify it will work for my use case prior to grabbing up a license. Past this one issue it’s worked great and incredibly quick, much more so than all the other various options.

In an update that will probably surprise absolutely nobody, I finished up my backup and restarted the container with the intent of testing the above scenarios and…it’s continuing to work perfectly fine :upside_down_face: If the problem persists I will update. I made a note of the machine id I had prior in case it changes.

@saspus @gchen

I rebooted my machine today and the issue has occurred again. According to the trial popup, I still have 17 days remaining on my trial, however I cannot resume a backup that was ongoing due to it stating my license is invalid or expired.

  • I’ve confirmed that /var/lib/dbus/machine-id is still symlinked to /config/machine-id
  • I’ve confirmed that both the above still have the original creation/modification date from Jan 20
  • I’ve confirmed that the licenses.json still has an original creation/modification date of Jan 20

One thing I will note is that, within duplicacy.json, computers lists the only entry with a name of localhost while the actual webui shows the hostname I am passing to the container. In fact, the passed in hostname for the container is not reflected in the duplicacy.json file anywhere. If I run the hostname command within the container I get the properly expected hostname. This makes me wonder, perhaps, if there is an issue where duplicacy is using an incorrect hostname or reference to localhost, then seeing that the requests are coming from the defined hostname, and thus thinking these are separate computers.

This would potentially be backed up by the fact that, looking on the dashboard, I see the previous actions I have manually performed being reflected as localhost-*, (localhost-1, localhost-2, …, localhost-8)

I’m going to keep this state for a bit to try and provide any other information I can upon request before doing the needed steps to continue with my backup testing.

Ironically, because (from what I read so far) trial license handling is different, addressing issues with it won’t affect your future use of the software with an actual license. It’s essentially trial of a wrong thing in this case — and needs to be fixed. (Even at the expense of requiring trial users to create an account. Otherwise users will give up seeing like even trial version does not work reliably)

In your case, not to fight windmills with trial licensing, it may be more productive to trial an actual code path that will be used if you decide license. If @gchen agrees you can buy a license with an option to get a refund in a month. Or maybe @gchen can generate you a paid license code with expiration date in a month in the future. Either options will give you one month trial or actual app behavior. Just my 2c.

I’m good with any of the options. I’ll hold in the “broken” state for now, pending input from @gchen in case he needs some more information from this state to help any sort of debugging.

I just PM’ed you a trial license code. With a code the license should stay valid after a reboot/restart.

For what its worth, since buying a license I never had the issue again.

so far, same here. Things are working smoothly

Same as well. Thanks for the trial license, @gchen. Since that point I’ve had no issues, and will be upgrading to a full license at the end of the trial.

Apparently, I’m another victim of license loss. See here:
https://forum.duplicacy.com/t/duplicacy-web-docker-fails/6099

I bought the license for the year in January and now its says the same thing, invalid license.

You can re-activate the license by clicking the link that says invalid license and enter the license active code.