Issues transfering Duplicacy install to new PC

So I followed the steps from this thread to transfer my Duplicacy install to a new install of Windows 10. I actually tried it twice to double check that I did everything correctly, and both times when I tried to start a backup, it instantly fails and I get this error:

2021-01-06 21:18:30.511 INFO REPOSITORY_SET Repository set to D:/
2021-01-06 21:18:30.512 INFO STORAGE_SET Storage set to E:/
2021-01-06 21:18:30.528 ERROR SNAPSHOT_LIST Failed to list the revisions of the snapshot BackupHD: mkdir E:/snapshots/BackupHD: The system cannot find the path specified.
Failed to list the revisions of the snapshot BackupHD: mkdir E:/snapshots/BackupHD: The system cannot find the path specified.

When I add the snapshot folder from my previous install, it still fails and gives me an error that it couldn’t find a specific chunk. If anyone can help me, I’d really appreciate it!

Obvious questions – is there disk E:? is this a network drive? is duplciacy running from administrator or system aсcount?

Thanks for your response. Yes, there’s a disk E (all drive names and letters are exactly the same as before), no it’s not a network drive, and yes it’s running from an admin account.

Does e:\snapshots folder exist?

Does administrator have permissions to write to and read from E: and E:\snaphosts?

The error message I described above is what happens when there is no snapshots folder. When I add one, it gives me this error:

2021-01-06 23:39:51.354 ERROR DOWNLOAD_CHUNK Chunk a1c75f3af87a2a73b49ad64782d0d59a5418b012a6a5724a8620ea104316b350 can’t be found
Chunk a1c75f3af87a2a73b49ad64782d0d59a5418b012a6a5724a8620ea104316b350 can’t be found

And yes, the admin does have permissions to read and write to that path.

Did you copy the duplicacy datastore to e:?

I tried to copy it once or twice and it wasn’t successful for some reason. It took a long time and I think it was crashing Windows Explorer.

So if you haven’t successfully copy the datastore how do you expect it to work?

Don’t copy with explorer – use robocopy instead. Or if you prefer GUI – I heard good things about https://freefilesync.org – however have’t used it myself.

1 Like

No need to be rude, if I knew the answer I obviously wouldn’t be on here asking for help. I’ll try your suggestions.

Wasn’t trying to be rude, just frustrated — had you mentioned in the beginning that you failed to copy the datastore we could have saved quite a bit of time triaging nonexistent issue.

2 Likes

My bad, I realized what I said probably confused you. So I just copied the original snapshots folder completely, but there were a lot of corrupt files. TerraCopy said there were 8107 errors. (It’s an old hard drive so I’m not surprised). I tested a backup in Duplicacy and it completed fine, but it gave me an error when I attempted to restore a file from that backup. I’m assuming the files are corrupt and that I need to start a new backup.

Is there a way to rebuild the database of the missing chunks or should I just delete and start over?

I see. There is no guarantee that those chunks and snapshots that did copy had not rotted. The snapshots are themselves kept in chunks, so if those are corrupted/lost recovery won’t work.

You could technically run check -chunks and delete all those that are corrupted; then create new snapshot ID and make a new backup; this may save you from uploading a few chunks.

But since this is a local drive – I would honestly start over with fresh datastore.

This would be a good opportunity to turn on erasure coding if you plan to keep the datastore on the hard drive without checksumming redundant filesystem – so that in the future when bad or rotten blocks develop there would be higher chance to recovering from them.

1 Like