Local copy killed

The last 2 weeks or so I keep have a problem with my local copy schedule. It says “killed”. the log file is below. ID of backup changed. This schedule is getting killed only after 2 minutes when nothing else on the machine is running. I have 4GB of RAM. CLI version is 2.6.1 and web version is 1.4.1. running in docker image.

Running backup command from /var/cache/duplicacy/repositories/localhost/0 to back up /source
Options: [-log backup -storage USB -threads 2 -stats]
2020-12-27 00:00:01.445 INFO REPOSITORY_SET Repository set to /source
2020-12-27 00:00:01.445 INFO STORAGE_SET Storage set to /USB/XXXXXXXXXXXXXXXXX
2020-12-27 00:00:32.421 INFO BACKUP_START Last backup at revision 153 found
2020-12-27 00:00:32.421 INFO BACKUP_INDEXING Indexing /source
2020-12-27 00:00:32.421 INFO SNAPSHOT_FILTER Parsing filter file /var/cache/duplicacy/repositories/localhost/0/.duplicacy/filters
2020-12-27 00:00:32.452 INFO SNAPSHOT_FILTER Loaded 5 include/exclude pattern(s)
2020-12-27 00:00:36.967 WARN LIST_SKIP Skipped non-regular file mariadb1/mysqld.sock
2020-12-27 00:02:17.386 INFO BACKUP_THREADS Use 2 uploading threads
signal: killed

I fear it is a RAM issue. I was climbing up to 2.8GB of ram usage and then it crashed again. I have never had this before. My files have hardly changed. So not sure why this is happening.

Update: ran the local copy also with the latest version of the CLI and same issue.

Yes, it’s likely not enough ram — it does not even complete enumerating files.

Try setting DUPLICACY_ATTRIBUTE_THRESHOLD=1 evn variable; it may help somewhat. Or add more ram. Or split backup into several pieces by file count.

Thanks a lot for your help. Strange that I never had a problem before. I only have 500GB of files in my local backup. I notice my Docker CE and Docker CE CLI received an update around 20th December and around this time I noticed the local backups being killed. Could it be that there is memory leak issue with Docker?? If I want to set DUPLICACY_ATTRIBUTE_THRESHOLD=1 in the Docker image how do I do this. I am using the GUI. Can I do this in the options for the backup?? Thanks

It depends on the number of files too, not just size.

When you can pass the environment variable to docker run command with the -e flag.

There should be a way to do that in the GUI too — in the container properties. In the same place where you define volume mappings and such.

What platform are you running on? You may not need to use docker in the first place.