Migrating to zstd


I’m attempting to use the latest CLI release (3.2.0) to migrate an existing storage to use zstd compression.

What I have attempted so far is to create a new copy-compatible storage with zstd enabled.

Unfortunately, it seems that whenever I specify -copy <NAME> during add the newly initialized storage is still using the default "compression-level": 100, even if -zstd and -zstd-level best is specified.

If I forego the -copy flag I get the desired "compression-level": 203.

Am I missing something fundamental here?

Is there a recommended way to migrate to zstd?

Thanks a lot!

1 Like

I tested initializing the second storage with -copy and then modifying the compression-level manually in the config file. This unfortunately resulted in a
Two storages are not compatible for the copy operation
when attempting to copy between them.

@gchen Do you have any plans on supporting a zstd migration workflow? It would be really really great if we could take advantage of zstd without losing all history.



Ah, I see now, zstd is probably not entirely done yet and my questions may be premature, as I just got this error when attempting to add a zstd storage to the UI:

UI is running CLI v3.2.0.


With this commit you should able to to upgrade the compression level of an existing storage (by copying to a new storage with zstd enabled).

I’ll make a new release later this week.


Thank you @gchen !

With your commit, I was able to initialize a new storage with both -copy and -zstd while confirming that the new storage had the desired compression method.

I was also able to add that new storage to the GUI without the previous error message.

A copy is now underway and I look forward to seeing what the difference will come out to in terms of compression.


hi…nudge for new release? :smiley_cat:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.