Multiple repositories, multiple storage -- Did I do it right?

I need a bit of help. I have setup Duplicacy, but I’m not sure I’ve done it right.

So here’s the scenario.

What to backup:
Windows system, 2 drives (C, D)

Where to backup:
local NAS (Unraid)

Unraid path to Duplicacy storage is /mnt/user/backup/duplicacy/lasse/. This is mapped to Windows as Z:\backup\duplicacy\lasse\.

I prefer to not have additional directories/files created in the repositories. So I used the -repository option. I was not able to init both repositories from Z:\backup\duplicacy\lasse\ so I created a directory for each repository. From these I did something like

Z:\backup\duplicacy\lasse\lasse_c> duplicacy init -storage-name unraid -repository c:\  lasse_c Z:\backup\duplicacy\lasse\ 

Z:\backup\duplicacy\lasse\lasse_d> duplicacy init -storage-name unraid -repository d:\  lasse_d Z:\backup\duplicacy\lasse\ 

I ran both backups once. I then tried to add Onedrive as secondary storage. This again gave me troubles, especially since I want the copying to be executed on the Unraid server. I ended up duplicating the unraid storage entry in the preferences file and modifying its paths to local paths. I was then able to add Onedrive as storage.

duplicacy add -e -copy unraid-local onedrive lasse_d one://backup/lasse

Strangly, even thou I was in /mnt/user/backup/duplicacy/lasse/lasse_d/, the onedrive entry was added to the preferences file under /mnt/user/backup/duplicacy/lasse/lasse_c/. I then just copied the entry to the second preferences file.

I saw the thread about dummy repository when copying, but I didn’t quite get it.

I now have the copying running, but I’m not sure whether it’s copying just one of the reposities or both.

If you don’t specify the repository id for the copy command, it will copy backups from all repositories from the local storage to onedrive, so you’ll just need to run the copy command from one repository.