No Storage Information Shown (Including on Graphs)


I use the web-ui and I’ve noticed that my check jobs are not returning any information about the storages. I have two, one using OneDrive and the other using a local HD.

In the Storage section, under each storage created it lists “Run a check job to retrieve stats”, even though I have run multiple with no results. On top of this, all of the graphs on the Dashboard and on the Storage page have nothing on them.

Lastly, in Restore, the revisions load endlessly making me worry that my backups are not going through properly. Would love any guidance!

Thanks in advance!

Edit: In Restore, the revisions do load, they just take a while, still worried about no information showing though

Does the check job compete successfully?

What is host OS, how are you running the app? In the container? Natively? As what user?

Yep, the check job completes on both of them.

Host OS is Linux Mint 20.3. I didn’t know there was various ways to run Duplicacy, but the GUI is in the browser if that helps? I’m running it as the main user (no other users on the computer).

The data that duplicacy displays in under ~/.duplicacy_web/stats. See if it has read and write permissions there. Also check duplicacy_web.log for any obvious faults

You definitely figured out the problem! In duplicacy_web.log it says “Failed to read the stat file for storage ‘storage’ … no such file or directory”

I was wondering though, how do I make sure Duplicacy has read and write permissions for ~/.duplicacy_web/stats? When I go to the permissions in properties for “stats”, I don’t see Duplicacy under the Group options. Forgive me, I’m still new to Linux, sorry!

You can change the group of that folder with this command:

sudo chgrp Duplicacy ~/.duplicacy_web/stats

I get this error when typing that command: chgrp: invalid group: ‘Duplicacy’

Would I have to create a Duplicacy group?

Sorry I thought Duplicacy is the user name that runs the web GUI. You just need to replace Duplicacy with your current user name.

No worries. Still didn’t fix it unfortunately. The command went through fine, but it didn’t change anything. The duplicacy_web.log still has this line in it: Failed to read the stat file for storage ‘main’: open /home/username/.duplicacy-web/stats/storages/main.stats: no such file or directory"

That error could mean that you haven’t run a check job after the permission change. Try to run a check job and see if there is any permission error in the log file.

Still not showing sadly any info and has the “Failed to read the stat file” line. I ran a check job after running the command and just ran it again to double check.

Make sure you have the directory /home/username/.duplicacy-web/stats/storage. If not, manually create one and make sure it is writable (so that new stats files can be created by Duplicacy).

That directory exists and has a .stats file in it for my backup. When I open the file, I can’t see any text. When I open the Permissions, I (the only user) have “Create and delete files” access. Does Duplicacy not use the user permissions?

Any last ideas? Or should I become content without the graphs?

This log message indicates that the main.stats doesn’t exist. You said there is a .stats file but is it main.stats?

Try to run a check job again and see what new error messages are in the log.

Yep, it is main.stats. Sorry for the confusion there.

It is fixed! I removed and added the storage back, updating the one.token file (since I’m using OneDrive), and now the stats file is working again. Not sure what caused it in the first place, but at least it is fixed. Thanks for your help!