Onedrive: failed to refresh the access token (SOLVED)


I am backing up from multiple computers to the same Onedrive storage using the very same Onedrive Token. I ran into a weird problem. Two of the computers are backing up all fine, but two are not. All the computers use the latest duplicacy version (3x Linux, 1x Win10) and the preferences files are “identical”. Here is the error message:

user@computer:$ duplicacy -d backup -storage “OneDrive”
Storage set to one://Backup/duplicacy/
Reading the environment variable DUPLICACY_ONEDRIVE_ONE_TOKEN
Reading one_token from preferences
Failed to load the OneDrive storage at one://Backup/duplicacy: failed to refresh the access token: 400 Unexpected response

What is this?:


Should I use the same Onedrive token for all the computers or different ones? I think this used to work all OK before.

The computers where the Onedrive backup works OK, there is no “POST” at all.

EDIT: I had an old one_token version. So the answer to my own question is that all the computers must use the same one_token, otherwise the backup fails.


In that case, could you mark this as solved?

Thanks, I needed a reply to do that :wink:

hmmmm, didn’t know you can’t mark as solved the OP.

Not a big deal, but the right way to answer your own question would be to post a reply to it. :slightly_smiling_face:

1 Like