OneDrive symlink failure on Win10 creators fall update

I run OneDrive on my 2nd internal hard drive (D:), so the OneDrive path is D:/OneDrive.

I have setup a repository on my main drive (C:) and have linked OneDrive into my repository with a symlink/junction.

Today I have just updated my PC to latest Windows 10 Creators fall update (build 1709), and now I get a symlink read failure;

“Failed to read the symlink D/OneDrive: Unhandled reparse point type 9000301a”

I had no problem before I did the update today, (previous build 1703)

Windows 10 Pro, x64.
I am not using Files-on-Demand feature.

Any ideas?


9000301a doesn’t appear to be a valid reparse point type, according to

Can you delete that symlink and recreate a new one?

I deleted the symlink and recreated it. Same error. Note the symlink actually points to my 2nd internal harddrive D:

Strangely, if I add a top level folder from my OneDrive then the symlink works correctly.

e.g. D:\OneDrive\Books … works correctly

So it only seems to be the symlink to the OneDrive folder itself that fails; “D:/OneDrive”

0x9000301a seems to be IO_REPARSE_TAG_CLOUD. However I couldn’t find any information for this type of reparse point.

Ok. Thanks. I suppose I have to wait and hope one day there is information about it.
Until then I just have to live with my workaround.