Pls help with error

So I started seeding the backup locally which is about 30tb. This weekend I finally moved the minio storage server to a remote location and wanted to continue the backup. It took a long time to index and then it started.

The problem is, after a few hours I got a “FAILED” message. I just tried again and after 5-6 hours of indexing it fails again and I am not sure why this is happening. Can someone help me out? I also just purchased Duplicacy because it seemed to be running well locally on my network, and now I am having problems :frowning:

2020-01-28 13:48:20.449 INFO BACKUP_START No previous backup found
2020-01-28 13:48:20.449 INFO BACKUP_INDEXING Indexing /backuproot/test
2020-01-28 13:48:20.449 INFO SNAPSHOT_FILTER Parsing filter file /cache/localhost/0/.duplicacy/filters
2020-01-28 13:48:20.449 INFO SNAPSHOT_FILTER Loaded 0 include/exclude pattern(s)
2020-01-28 13:48:30.844 INFO INCOMPLETE_LOAD Incomplete snapshot loaded from /cache/localhost/0/.duplicacy/incomplete
2020-01-28 13:48:30.844 INFO BACKUP_LIST Listing all chunks
2020-01-28 20:57:02.056 ERROR LIST_FILES Failed to list the directory chunks/: SerializationError: failed to decode REST XML response
caused by: http2: server sent GOAWAY and closed the connection; LastStreamID=1999, ErrCode=NO_ERROR, debug=""
Failed to list the directory chunks/: SerializationError: failed to decode REST XML response

EDIT: By the way, this is the only backup ID that seems to be having this issue. It also happens to be the largest folder that’s over 30TB and it was running on the local network for about 1 week before I moved the backup target to a remote location before it finished to continue. Not sure what is happening?

The minio sever log may have an explanation why it closed the connection. My guess is that there is probably a limit on how long a listing session can be kept open.

Would it be possible to switch to sftp? The sftp backend should work better for listing the chunks directory (which is only need for the first backup).

oh no :frowning:
sftp would not be possible. It took me almost a year to figure out the right backup way and it’s running unraid, Letsencrypt and minio.

What can I do to get this working? I did not come across this issue anywhere when researching the software

This might be a go bug according to GOAWAY retry · Issue #1196 · minio/minio-go · GitHub

There is a way to avoid the chunk listing phase needed by an initial backup: move all chunks out of the chunks directory, create an empty backup using the same backup id (by adding an exclude pattern -*), then move all old chunks back in. The next backup will not list the chunks directory (remember to use multiple threads with the -threads option).

The sftp backend might be simpler than this. What prevented you from using sftp? It is much easier to set up than minio.

oh wow, that’s too much and sftp is not a simple set up in unraid. I’m using minio in unraid which is linux. I did not have this issue when it was on the local network though still using minio

Can you try using the s3c backend instead? You can just modify the storage url in ~/.duplicacy-web/duplicacy.json from minio://... to s3c://... (while the web GUI is not running).

Thanks gchen! Changing it to s3c worked!
Could you explain a little about what the s3c is and why it’s working with s3c and not minios how I had it before? Is s3c not encrypted? Thanks so much, I’m glad it is working!

The s3 backend uses the official s3 client library ( while the s3c backend uses a third-party one (GitHub - goamz/goamz: Amazon AWS Library for Go). I didn’t take a closer look, but it is very likely that the goamz library doesn’t use http2 so it isn’t affected by the bug in go (although there might be a way to disable http2 in aws-sdk-go).

I had to restart my server, yesterday, and duplicacy failed AGAINm but this time with a different error.

2020-02-01 23:41:26.572 INFO BACKUP_LIST Listing all chunks
2020-02-01 23:45:27.102 ERROR LIST_FILES Failed to list the directory chunks/: 504 Gateway Time-out
Failed to list the directory chunks/: 504 Gateway Time-out

Not sure why this keeps happening? So now . I had to start again and it’s going to be “indexing” for 7 hours again before i even find out if it could get started again?

Do you have anything between the local computer and the minio server? I thought the minio server along wouldn’t give the 504 error?

I still think the sftp backend is better. If you are ok with accessing as root, it should work out of the box with unraid. For example:

duplicacy init test sftp://root@ip//mnt/user/storage/test

I am still having issues and sent you a pm that I would like to cancel duplicacy. It is not working out unfortunately.