Pre/Post command scripts not running Web GUI


I am trying to run a simple script before my backup job to stop my docker containers and start then after but all of the scripts I try to run are not executed.

I followed the steps here:

Tried with a dummy script that is chmod 777 +x :

echo "Stopping all docker containers" > text.txt
exit 0

I have tried with the following paths:

And other commands and still nothing is executed.

I can’t find any thing more recent that the topic linked.

Any help would be greatly aprpeciated!

Do you see in the backup log the evidence of the script being attempted to get executed?

You may need to add global -d flag to see more verbose logging.

I also suggest specifying full path to your test.txt file to avoid confusion with what is current directory is supposed to be.

There is nothing in the log to indicate it is running the script.

I switched the path to the full path and still no luck.

With -d logging the first message is still:

Running backup command from /.duplicacy-web/repositories/localhost/0 to back up /backupdir

After that it is all related to backing up to the storage.

Looking at the source, unless “no-script“ is set in preferences somewhere, it should execute the script named “pre-backup” located under scripts folder under .duplicacy folder.

I have just figured it out when trying a fresh install.

Everything is working fine I was just in the wrong directory :flushed:

I had the whole folder structure in my home folder which is where I was adding the scripts. However duplicacy was actually running out of the filesystem root instead of my home directory.

Not entirely sure how I got both directories but I was experimenting with some other docker images and such before using the standard web executable.

Thanks for the help!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.