Problem with backup


Is there any problem with long non English characters in folder/filenames ? I’m getting some errors like this one.

Failed to list subdirectory: open \?\\host\backup a???st???S ??S???S??? ?G. ???G??O??? ?G. ???G??O???F???S ???SF?G? ??: The filename, directory name, or volume label syntax is incorrect.

Duplicacy should be able to handle non English folder/filenames. Why does the path start with ?\host\backup? Is the repository (the directory to be backed up) on a networked drive?

Yes it’s a samba share.

The fact that Duplicacy reported an error on this directory means that it successfully listed its parent directory. So there must be something wrong with this particular directory.

Can you browse that directory in File Explorer? Does it contain any characters that can’t be used in valid paths?

There are quite a lot of directories with the same error that doesn’t backup, all with non English characters. Does it matter if it’s too deep (12th subdirectory) ? Yes I can browse every folder just fine and no problem using rclone or rsync.

This is a bug. The path \\?\\\host\backup is incorrect; the correct one should be \\?\UNC\host\backup.

I’ve fixed it in this commit which will get into 2.0.9. For a workaround with the 2.0.8 version you can map the samba drive to a drive and then select the directory on the mapped drive as the repository.

Thank you, that fixed the problem.