Prune command brings "Invalid Options"

We had the prune command in our daily schedule set to:

-keep 0:1800 -keep 7:30 -keep 1:7 -a -exclusive

We changed it to

-keep 0:365 -keep 7:30 -keep 1:7 -a -exclusive

to make some space in the backup desitnation. Problem is, no space is freed.

  • is there a way to check how much space a revision is taking?
  • did we miss something that prevents the space from freed up?

Did -keep 0:365 -keep 7:30 -keep 1:7 -a -exclusive give you “Invalid Options”?

The log of a prune job can tell you how many chunks have been deleted. The log of a check job will show you the space taken by each revision.

ok, thanks. the prune is working fine, but there is indeed a backup source which takes a lot of space. We don’t actually need 365 days retention for this particular directory, so is there a way to either reduce the retention for this source (only) or to have two scheduled jobs, so that I can prune just this directory?

Noticed this hadn’t been answered…

To have a separate prune policy, you’d have to swap out the -a flag with -id <snapshot>.

Normally, you’d have to account for the other snapshots and probably prune them individually as well (since there’s no equivalent to -a minus -id), but since you only wanna curtail the revisions from 365 days to lower, you could keep the existing prune -keep whatever -a and do an additional prune -keep 0:90 -id blah.

Incidentally, the reason you didn’t see space being freed up after the first prune, is because Duplicacy does this in two steps. :slight_smile: