Prune command is not working as expected

hi there,

I have tried to play around with pruning but I’m afraid I can’t figure out, how it works.
I have 2x 1 TB Cloud Storage and I had to delete both storages completely and begin from scratch since prune didn’t work and the storage ran out of space after a while.

I wan’t to delete every revision that is older than 30 days.
I have this command running every Wednesday:

So i would expect all revisions to be deleted older than 28.09.2023

But it just won’t work.
I run the prune command already twice since i know the first time nothing will be deleted.

But the revisions are all still there and the next time my backup runs, my storage is full :frowning:

Since I can’t upload two pictures here is what my revision table looks like when I try to restore something in text:

revision 8 created at 2023-11-02
revision 7 created at 2023-10-19
revision 6 created at 2023-10-12
revision 5 created at 2023-09-28
revision 4 created at 2023-09-21
revision 3 created at 2023-09-14
revision 2 created at 2023-09-07
revision 1 created at 2023-09-05 -hash

What am I doing wrong?
I just wan’t duplicacy to run automatically, do weekly backups and delete every file older than 30 days.

Thanks in advance!


The parameters for prune shall include -a to prune all snapshot ids, or -id … to prune specific snapshot id.

There is no need to run exhaustive prune.

thanks for reply!

I tried to launch “-keep 0:30 -a” for 2 times now and nothing chanced.
Every revision is still available and blocking my storage.


What am I doing wrong?